summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-12-14 00:56:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-28 10:53:23 +0100
commit708b29a3958fa86d705e998c64360909a4e541bc (patch)
tree1f44903633777841a41e483c5b768d966c600b78
parentdade225788ee162bdbdc77385f77c891c6b3c781 (diff)
gnu: Add pdfcrack.
* gnu/packages/pdf.scm (pdfcrack): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/pdf.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 19e10649f3..c4b1b3fb46 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1203,6 +1204,35 @@ information for every pixel as the input.")
the framebuffer.")
(license license:gpl2+)))
+(define-public pdfcrack
+ (package
+ (name "pdfcrack")
+ (version "0.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/pdfcrack/pdfcrack/"
+ "pdfcrack-" version "/"
+ "pdfcrack-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d751n38cbagxqpw6ncvf3jfv7zhxl3fwh5nms2bjp6diyqjk2vv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ (lambda _
+ (install-file "pdfcrack"
+ (string-append #$output "/bin")))))))
+ (home-page "https://pdfcrack.sourceforge.net/")
+ (synopsis "Password recovery tool for PDF files")
+ (description "PDFCrack is a simple tool for recovering passwords from PDF
+documents that use the standard security handler.")
+ (license license:gpl2+)))
+
(define-public pdf2svg
(package
(name "pdf2svg")