summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 13:19:25 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:05 +0200
commit709a5a9365ac6115d9f8ddd29502f78f70649497 (patch)
tree2361cf5995530c7c9add1dde1aa37883c25200c7
parent75805449cfbcf41c530a4faaa7d8d69933aa6b40 (diff)
gnu: Add python-webassets.
* gnu/packages/python.scm (python-webassets, python2-webassets): New variables.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a2560916d7..6ee3163c6f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14216,3 +14216,27 @@ make common patterns shorter and easier.")
(define-public python2-utils
(package-with-python2 python-utils))
+
+(define-public python-webassets
+ (package
+ (name "python-webassets")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "webassets" version))
+ (sha256
+ (base32
+ "1nrqkpb7z46h2b77xafxihqv3322cwqv6293ngaky4j3ff4cing7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-jinja2" ,python-jinja2)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/miracle2k/webassets")
+ (synopsis "Media asset management")
+ (description "Merges, minifies and compresses Javascript and CSS files,
+supporting a variety of different filters, including YUI, jsmin, jspacker or
+CSS tidy. Also supports URL rewriting in CSS files.")
+ (license license:bsd-2)))