summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-18 10:30:08 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-18 11:04:22 +0100
commit72a06d3e32700dbf30409e1ace8f3989680dd680 (patch)
tree273337b87ceb5c2144d1f7c023891b328a7a8525
parentd8c18af834c492a2066e882fed95062a5c33fbc7 (diff)
gnu: goffice: Add "doc" output.
* gnu/packages/gnome.scm (goffice)[outputs, arguments]: New fields. (goffice-0.8)[arguments]: Append arguments from GOFFICE.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1ace5943e5..59e43dcc96 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1470,6 +1470,12 @@ Hints specification (EWMH).")
(sha256
(base32 "0nmghi26dpjcw7knkviq031crhm0zjy4k650pv1jj3hb1fmhx9yd"))))
(build-system gnu-build-system)
+ (outputs '("out"
+ "doc")) ;4.1 MiB of gtk-doc
+ (arguments
+ '(#:configure-flags (list (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html"))))
(inputs
`(("gtk+" ,gtk+)
("libgsf" ,libgsf)
@@ -1507,7 +1513,9 @@ Hints specification (EWMH).")
;; https://bugzilla.gnome.org/show_bug.cgi?id=670316
(substitute* "configure"
(("glib/gregex\\.h") "glib.h")) #t)
- %standard-phases)))
+ %standard-phases)
+
+ ,@(package-arguments goffice)))
(propagated-inputs
;; libgoffice-0.8.pc mentions libgsf-1
`(("libgsf" ,libgsf)))