summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-23 12:11:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-24 12:13:05 +0100
commit733b600eec5b62874c6d0f1b85e5f358c6d76c30 (patch)
treefdfc8ae2438d3d1f82f5bc2e0c30135d27a14694
parent545ae3652e12221c5cacf41c2ff05f99e14622cd (diff)
gnu: Add r-fontawesome.
* gnu/packages/cran.scm (r-fontawesome): New variable.
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 368ef827a4..e689bc42cc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -581,6 +581,31 @@ ordered indexed observations. It is particularly aimed at irregular time
series of numeric vectors/matrices and factors.")
(license license:gpl2+)))
+(define-public r-fontawesome
+ (package
+ (name "r-fontawesome")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fontawesome" version))
+ (sha256
+ (base32 "0r6zb5175cr4ybqj6bl0mbhadwv9xjxaf32yjc0y76rw3d6vcbap"))))
+ (properties `((upstream-name . "fontawesome")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/rstudio/fontawesome")
+ (synopsis "Easily work with Font Awesome icons")
+ (description
+ "Easily and flexibly insert Font Awesome icons into R Markdown documents
+and Shiny apps. These icons can be inserted into HTML content through inline
+SVG tags or @code{i} tags. There is also a utility function for exporting
+Font Awesome icons as PNG images for those situations where raster graphics
+are needed.")
+ (license license:expat)))
+
(define-public r-fingerprint
(package
(name "r-fingerprint")