summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-04-26 09:10:06 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-05-09 06:43:35 +0200
commit73818c254b8a833dc474105b9c3fb66b86227fc4 (patch)
tree28a3d6aa9d5cb46871825c50aec7b75ab3e14bfe
parent1b6f231c51df22b6689adb3d23499c79e1daebe4 (diff)
gnu: Add emacs-ellama.
* gnu/packages/emacs-xyz.scm (emacs-ellama): New variable. Change-Id: I47bf40971adca845aa132d08f59cd083154bec0e Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7eef10b856..ab26609303 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4998,6 +4998,31 @@ environment set through Direnv.")
that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))
+(define-public emacs-ellama
+ (package
+ (name "emacs-ellama")
+ (version "0.9.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s-kostyaev/ellama")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1nwwqvl91c65r45yxa2dcl4a41r3ahw6294h79riya48nrp8kn54"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-dash emacs-llm emacs-spinner))
+ (home-page "https://github.com/s-kostyaev/ellama")
+ (synopsis "Tool for interacting with LLMs")
+ (description
+ "Ellama is a tool for interacting with large language models from Emacs.
+It allows you to ask questions and receive responses from the LLMs. Ellama
+can perform various tasks such as translation, code review, summarization,
+enhancing grammar/spelling or wording and more through the Emacs interface.
+Ellama natively supports streaming output, making it effortless to use with
+your preferred text editor.")
+ (license license:gpl3+)))
+
(define-public emacs-org-fc
(package
(name "emacs-org-fc")