summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-28 20:53:59 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-15 23:33:12 +0000
commit74cab6cd03186916486da34cb49519f9f16b6a32 (patch)
tree656e566c611c00541bd1c41c015d284599349ddd
parent868e21bb76728f460cf16e21fbf38e54df32819f (diff)
gnu: go-github-com-blang-semver: Update to 3.8.0.
* gnu/packages/golang-xyz.scm (go-github-com-blang-semver): Update to 3.8.0. Change-Id: I5f1eec936236e4f8984d6aabbab9a9ce99e291a3
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..5734a50c95 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -285,20 +285,18 @@ information and periodically output metrics")
(license license:expat)))
(define-public go-github-com-blang-semver
- (let ((commit "60ec3488bfea7cca02b021d106d9911120d25fe9")
- (revision "0"))
(package
(name "go-github-com-blang-semver")
- (version (git-version "0.0.0" revision commit))
+ (version "3.8.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/blang/semver")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19pli07y5592g4dyjyj0jq5rn548vc3fz0qg3624vm1j5828p1c2"))))
+ (base32 "16s66zbfkn35msmxpkiwf5dv91kzw7yzxzkcv8ma44j7lbgzx5qk"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/blang/semver"))
@@ -306,7 +304,7 @@ information and periodically output metrics")
(synopsis "Semantic versioning library written in Go")
(description
"Semver is a library for Semantic versioning written in Go.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-bmizerany-perks-quantile
(package