summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 00:12:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 00:12:55 -0400
commit7612610c44f16fc8f2ff395d9a2d58101a7356aa (patch)
tree4b0679bbcb51881746fdaa1972f5cc92354db07a
parent06c84f731acf8100b030e627ccc87ee7a2ad7322 (diff)
gnu: python-afdko: Update to 3.9.5.
* gnu/packages/fontutils.scm (python-afdko): Update to 3.9.5. [source]: Remove obsolete substitutions in snippet. [arguments]: Re-instate all skipped tests in check phase.
-rw-r--r--gnu/packages/fontutils.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 65f28de017..ffaaa5caca 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -148,22 +148,16 @@ them as it goes.")
(define-public python-afdko
(package
(name "python-afdko")
- (version "3.9.4")
+ (version "3.9.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "afdko" version))
(sha256
- (base32 "1d3b1590gxlindh1sjhwvxnryn5zil98hgdwbgsr76fd657r3f99"))
+ (base32 "02c1rjx7ggbd1m9vqgsc2r28yiw66cjgvs5cq1a2fz0lkadbvrnb"))
(modules '((guix build utils)))
(snippet
#~(begin
- (substitute*
- "tests/buildcff2vf_data/expected_output/SHSansJPVFTest.ttx"
- ;; Adjust expected output to match newer fonttools. Taken from:
- ;; https://github.com/adobe-type-tools/afdko/commit/7c526390a10e
- (("FDSelect format=\"3\"")
- "FDSelect format=\"0\""))
(with-directory-excursion "c/makeotf/lib/hotconv"
;; Delete ANTLR-generated code.
(for-each delete-file
@@ -223,17 +217,7 @@ them as it goes.")
(when tests?
(setenv "HOME" "/tmp")
(invoke "pytest" "-vv" "--dist" "loadfile" "-n"
- (number->string (parallel-job-count))
- ;; This test is known to fail on multiple architectures.
- ;; https://github.com/adobe-type-tools/afdko/issues/1163
- "-k"
- (string-append
- "not test_type1mm_inputs "
- ;; These tests fail for unknown reasons (see:
- ;; https://github.com/adobe-type-tools/afdko/issues/1635).
- "and not test_rvrn_vf "
- "and not test_cjk_vf "
- "and not test_sparse_cjk_vf")))))
+ (number->string (parallel-job-count))))))
(add-after 'check 'wrap
(assoc-ref %standard-phases 'wrap))
(add-before 'wrap 'wrap-PATH