summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 13:13:04 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 16:27:36 +0100
commit78257b564c14521e357cb900ca53172e5417522b (patch)
tree83ba3e70c7eb618fad2a92d35a740bbdaa9f93d3
parent46a9857ab0fffbe6360e925a808dda6e3a835971 (diff)
gnu: Remove go-github-com-multiformats-go-multihas-0.2.3.
* gnu/packages/golang-crypto.scm (go-github-com-multiformats-go-multihas): Update to 0.2.3. * gnu/packages/golang-crypto.scm (go-github-com-multiformats-go-multihas-0.2.3): Revmoe variable. * gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr-0.12): [propagated-inputs]: Swap go-github-com-multiformats-go-multihas-0.2.3 to go-github-com-multiformats-go-multihas. * gnu/packages/ipfs.scm (go-github-com-ipfs-go-cid): [propagated-inputs]: Swap go-github-com-multiformats-go-multihas-0.2.3 to go-github-com-multiformats-go-multihas. * gnu/packages/ipfs.scm (kubo): [inputs]: Swap go-github-com-multiformats-go-multihas-0.2.3 to go-github-com-multiformats-go-multihas. Change-Id: Ic183a091d05cf93ba7cf430e59bb239951f1384a
-rw-r--r--gnu/packages/golang-crypto.scm38
-rw-r--r--gnu/packages/golang-web.scm2
-rw-r--r--gnu/packages/ipfs.scm4
3 files changed, 9 insertions, 35 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index ca35d5c391..989570c868 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -840,37 +840,6 @@ Architecture Processors\" by J. Guilford et al.")
(define-public go-github-com-multiformats-go-multihash
(package
(name "go-github-com-multiformats-go-multihash")
- (version "0.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/multiformats/go-multihash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1aw4ra22g3l98bk7c3h1n968vi5a3gk528g4byj3xig76r0r731n"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/multiformats/go-multihash"))
- (propagated-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-gxed-hashland-murmur3
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-golang-org-x-crypto))
- (home-page "https://github.com/multiformats/go-multihash")
- (synopsis "Multihash implementation in Go")
- (description "Multihash implementation in Go.")
- (license license:expat)))
-
-;; XXX: Remove it when all dependent packages are ready to be updated.
-(define-public go-github-com-multiformats-go-multihash-0.2.3
- (package
- (inherit go-github-com-multiformats-go-multihash)
- (name "go-github-com-multiformats-go-multihash")
(version "0.2.3")
(source
(origin
@@ -881,6 +850,7 @@ Architecture Processors\" by J. Guilford et al.")
(file-name (git-file-name name version))
(sha256
(base32 "0ydh94083888xl2r4d1grzgqf3c818mkmdpj008jkh6h7m56wc4w"))))
+ (build-system go-build-system)
(arguments
(list #:go go-1.21
#:import-path "github.com/multiformats/go-multihash"
@@ -909,7 +879,11 @@ Architecture Processors\" by J. Guilford et al.")
go-github-com-multiformats-go-varint
go-github-com-spaolacci-murmur3
go-golang-org-x-crypto
- go-lukechampine-com-blake3))))
+ go-lukechampine-com-blake3))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat)))
(define-public go-github-com-operatorfoundation-ed25519
(let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index cdde16bf06..0879d496cf 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1390,7 +1390,7 @@ following:
(propagated-inputs (list go-github-com-ipfs-go-cid
go-github-com-multiformats-go-multibase
go-github-com-multiformats-go-varint
- go-github-com-multiformats-go-multihash-0.2.3
+ go-github-com-multiformats-go-multihash
go-golang-org-x-exp-2023))))
(define-public go-github-com-multiformats-go-multiaddr-dns
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index dc8388acfc..f363da7e29 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -58,7 +58,7 @@
#:go go-1.21
#:import-path "github.com/ipfs/go-cid"))
(propagated-inputs
- (list go-github-com-multiformats-go-multihash-0.2.3
+ (list go-github-com-multiformats-go-multihash
go-github-com-multiformats-go-multibase
go-github-com-multiformats-go-varint))
(home-page "https://github.com/ipfs/go-cid")
@@ -369,7 +369,7 @@ written in Go.")
go-github-com-minio-sha256-simd
go-github-com-mitchellh-go-homedir
go-github-com-mr-tron-base58
- go-github-com-multiformats-go-multihash-0.2.3
+ go-github-com-multiformats-go-multihash
go-github-com-multiformats-go-multiaddr
go-github-com-multiformats-go-multibase
go-github-com-multiformats-go-multiaddr-dns