summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:02:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:41 +0200
commit78e7c677f471b734260e28d733eb8805e1fb2c1c (patch)
tree02d793e3e4385db1fd3322fbce18589384e54ba5
parent02da2c8c8a36ca65f3afcefa2894cf10206deaa2 (diff)
gnu: Add texlive-present.
* gnu/packages/tex.scm (texlive-present): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 03cda07c15..ab8a95f065 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3478,6 +3478,29 @@ manually.")
Mary's Road fonts, in a Plain TeX environment.")
(license license:public-domain)))
+(define-public texlive-present
+ (package
+ (name "texlive-present")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/present/" "tex/plain/present/")
+ (base32
+ "1dc7h14z7xw232mgqjayl1a4ab5pj9bz2d9wgmznh4bjylgw4lwp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/present")
+ (synopsis "Presentations with Plain TeX")
+ (description
+ "The package offers a collection of simple macros for preparing
+presentations in Plain TeX. Slide colour and text colour may be set, links
+between parts of the presentation, to other files, and to web addresses may be
+inserted. Images may be included easily, and code is available to provide
+transition effects between slides or frames. The structure of the macros is
+not overly complex, so that users should find it easy to adapt the macros to
+their specific needs.")
+ (license license:lppl)))
+
(define-public texlive-tex
(package
(name "texlive-tex")