summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-19 10:33:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-19 10:33:19 +0200
commit797585746b1e74aa47f06f0e757cbb6c0a262088 (patch)
tree4a8494c21dcd5bec70e4e47ccbf26e771941505f
parent63806fedf27024644c33e8c34fb594c5474bf3a1 (diff)
gnu: freebayes: Extend test timeout on slower architectures.
* gnu/packages/bioinformatics.scm (freebayes)[arguments]: Use custom 'check phase on aarch64-linux and armhf-linux to extend the test timeout.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9d9cd05969..908ae8a194 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -143,6 +143,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
#:use-module (ice-9 match))
(define-public aragorn
@@ -15168,7 +15169,16 @@ manipulations on VCF files.")
(unpack "vcflib-src" "vcflib")
(unpack "intervaltree-src" "vcflib/intervaltree")
(unpack "test-simple-bash-src" "test/test-simple-bash"))
- #t))))))
+ #t)))
+ ;; The slow tests take longer than the specified timeout.
+ ,@(if (any (cute string=? <> (%current-system))
+ '("armhf-linux" "aarch64-linux"))
+ '((replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "meson" "test" "--timeout-multiplier" "5"))
+ #t)))
+ '()))))
(home-page "https://github.com/ekg/freebayes")
(synopsis "Haplotype-based variant detector")
(description "FreeBayes is a Bayesian genetic variant detector designed to