summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-27 23:15:02 +0100
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:09:36 +0000
commit7995a474eab286a0eb05b065716ecd026a681d56 (patch)
tree24996e359ca764d27a0ceb0d88987380a21e5848
parent9f06cf2ed8e8d5b4452c7b08d7521ec532e58f67 (diff)
gnu: python-asdf: Update to 3.0.0.
* gnu/packages/astronomy.scm (python-asdf-3.0): New variable, migrated from python-asdf. [arguments]: Move it from here ... [native-inputs]: Remove python-astronomy, python-pytest-openfiles. [propagated-inputs]: Add python-attrs. Remove python-importlib-resources, python-jsonschema. (python-asdf-2.15): New variable. Inherited from python-asdf-3.0. [arguments]: ... to here. (python-asdf): Set it to use python-asdf-2.15 as 3.0.0 includes some breaking changes which may not testes in dependent projects. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm48
1 files changed, 33 insertions, 15 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fb0583e7f6..47913a1282 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3769,32 +3769,23 @@ between image and reference catalogs. Currently only aligning images with
@code{FITS WCS} and @code{JWST gWCS} are supported.")
(license license:bsd-3)))
-(define-public python-asdf
+(define-public python-asdf-3.0
(package
(name "python-asdf")
- (version "2.15.0")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asdf" version))
(sha256
- (base32 "11s56797l5330kkhppkyz0bsvms016knmyswj4gx91zrxf8iqvv8"))))
+ (base32 "1a6lf75q9w8fsyq3hn6a7fyldkkyqxddlq21fwdfjwij40dzh3s8"))))
(build-system pyproject-build-system)
- (arguments
- (list #:test-flags
- #~(list "-k" (string-append
- "not test_overwrite"
- " and not test_tagging_scalars"
- " and not test_info_command"
- " and not test_array_inline_threshold_recursive"))))
(native-inputs
- (list python-astropy
- python-fsspec
+ (list python-fsspec
python-packaging
python-psutil
python-pytest
python-pytest-doctestplus
- python-pytest-openfiles
python-pytest-remotedata
python-semantic-version
python-setuptools-scm))
@@ -3802,10 +3793,9 @@ between image and reference catalogs. Currently only aligning images with
(list python-asdf-standard
python-asdf-transform-schemas
python-asdf-unit-schemas
+ python-attrs ;; for vendorized jsonschema
python-importlib-metadata
- python-importlib-resources
python-jmespath
- python-jsonschema
python-lz4
python-numpy
python-pyyaml))
@@ -3817,6 +3807,34 @@ interchange format for scientific data. This package contains the Python
implementation of the ASDF Standard.")
(license license:bsd-3)))
+(define-public python-asdf-2.15
+ (package
+ (inherit python-asdf-3.0)
+ (version "2.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf" version))
+ (sha256
+ (base32 "11s56797l5330kkhppkyz0bsvms016knmyswj4gx91zrxf8iqvv8"))))
+ (arguments
+ (list #:test-flags
+ #~(list "-k" (string-append
+ "not test_overwrite"
+ " and not test_tagging_scalars"
+ " and not test_info_command"
+ " and not test_array_inline_threshold_recursive"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs python-asdf-3.0)
+ (prepend python-astropy python-pytest-openfiles)))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-asdf-3.0)
+ (prepend python-jsonschema python-importlib-resources)))))
+
+(define-public python-asdf
+ ;; Default version of ASDF..
+ python-asdf-2.15)
+
(define-public python-asdf-standard
(package
(name "python-asdf-standard")