summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-03 17:55:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-11 18:13:43 +0200
commit7a48471d78ba9686a4ac2fcdda127c4607df5314 (patch)
tree4447bc3f39a1cc2770e8654e323a48624b3d5f8a
parenta181022a51b5b7f7cdcbf465c5e2aa2713f70290 (diff)
gnu: texlive-latex-epstopdf-pkg: Fix package definition.
* gnu/packages/tex.scm (texlive-latex-epstopdf-pkg)[arguments]: Generate from source. [propagated-inputs]: Add TEXLIVE-GRFEXT, TEXLIVE-INFWARERR, TEXLIVE-KVOPTIONS and TEXLIVE-PDFTEXCMDS.
-rw-r--r--gnu/packages/tex.scm57
1 files changed, 41 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4c681f4f77..a8fc98e7f7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3295,22 +3295,47 @@ the @file{.aux} file.")
(define-deprecated-package texlive-latex-auxhook texlive-auxhook)
(define-public texlive-latex-epstopdf-pkg
- (package
- (inherit (simple-texlive-package
- "texlive-latex-epstopdf-pkg"
- '("/doc/latex/epstopdf-pkg/"
- "/tex/latex/epstopdf-pkg/")
- (base32
- "0zl6jiyp2cvvyqx3lwxdkcvvnkqgbwj4issq07cagf61gljq6fns")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/epstopdf-pkg")
- (synopsis "Call @command{epstopdf} \"on the fly\"")
- (description
- "The package adds support for EPS files in the @code{graphicx} package
-when running under pdfTeX. If an EPS graphic is detected, the package
-spawns a process to convert the EPS to PDF, using the script
-@command{epstopdf}.")
- (license license:lppl1.3c+)))
+ (let ((template (simple-texlive-package
+ "texlive-latex-epstopdf-pkg"
+ (list "doc/latex/epstopdf-pkg/"
+ "source/latex/epstopdf-pkg/"
+ "tex/latex/epstopdf-pkg/")
+ (base32
+ "1ajyc5pkn1niifz5asyf09vbdqvmy05xwl0vxcdl7ik0ll0jcaxp"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/epstopdf-pkg")
+ ((#:build-targets _ '())
+ #~(list "epstopdf.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/epstopdf-pkg")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (propagated-inputs
+ (list texlive-grfext
+ texlive-infwarerr
+ texlive-kvoptions
+ texlive-pdftexcmds))
+ (home-page "https://www.ctan.org/pkg/epstopdf-pkg")
+ (synopsis "Call @command{epstopdf} on the fly")
+ (description
+ "The package adds support for EPS files in the @code{graphicx} package
+when running under pdfTeX. If an EPS graphic is detected, the package spawns
+a process to convert the EPS to PDF, using the script @command{epstopdf}.")
+ (license license:lppl1.3c+))))
(define-public texlive-latex-filecontents
(package