summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-07-30 11:16:38 -0300
committerVinicius Monego <monego@posteo.net>2023-09-30 10:37:43 -0300
commit7a53bd61a02e77074aca2693ba4909f196d5ce69 (patch)
treefaa59ababc0aceb522db6642b14d3834f7d2ae95
parentee5de9cdf2e9d914638fcac8b5f25bdddfb73dfc (diff)
gnu: Add hmat.
* gnu/packages/maths.scm (hmat): New variable.
-rw-r--r--gnu/packages/maths.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index efb0f99181..31fd3cebee 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1292,6 +1292,30 @@ plotting engine by third-party applications like Octave.")
(license (license:fsf-free
"http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
+(define-public hmat
+ (package
+ (name "hmat")
+ (version "1.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeromerobert/hmat-oss")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ssjzf3sdhn80w03bhp694s413222cl0100bf36mx70q3a1b6vi5"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; Examples are the tests.
+ (list #:configure-flags #~(list "-DBUILD_EXAMPLES=ON")))
+ (inputs (list openblas))
+ (home-page "https://github.com/jeromerobert/hmat-oss")
+ (synopsis "Hierarchical matrix library")
+ (description "@code{hmat-oss} is hierarchical matrix library written in
+C++ with a C API. It contains a LU and LLt solver, and a few other things.")
+ (license license:gpl2+)))
+
(define-public gctp
(package
(name "gctp")