summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-30 21:06:07 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:28 +0200
commit7b9d920340ceb2adc7e429e37a5faf0d6004dca1 (patch)
treef461539e140c659fcc77e0ba301cb513a1ee338c
parent32aba429d0e8b33fae4384169cad3776bd59a4b3 (diff)
gnu: Add rust-librespot-connect-0.4.
* gnu/packages/crates-io.scm (rust-librespot-connect-0.4): New variable. Change-Id: Id941f6a9865adfcb72df41fea017f1d45d6dc2c3
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fb923a603d..a4f4ce7aa6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Steve George <steve@futurile.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40274,6 +40275,39 @@ single-cell and single-nucleus sequencing data.")
package contains the audio fetching logic.")
(license license:expat)))
+(define-public rust-librespot-connect-0.4
+ (package
+ (name "rust-librespot-connect")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "librespot-connect" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1v6k20173hx27g34d24vkb4a67av7dbr3mfmng64b51y8imgpyjg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-form-urlencoded" ,rust-form-urlencoded-1)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-librespot-core" ,rust-librespot-core-0.4)
+ ("rust-librespot-discovery" ,rust-librespot-discovery-0.4)
+ ("rust-librespot-playback" ,rust-librespot-playback-0.4)
+ ("rust-librespot-protocol" ,rust-librespot-protocol-0.4)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-protobuf" ,rust-protobuf-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-stream" ,rust-tokio-stream-0.1))))
+ (home-page "https://github.com/librespot-org/librespot")
+ (synopsis "Discovery and Spotify Connect logic for Librespot")
+ (description
+ "Librespot is an open source client library for Spotify. This package
+contains the discovery and Spotify Connect logic.")
+ (license license:expat)))
+
(define-public rust-librespot-core-0.4
(package
(name "rust-librespot-core")