summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-20 16:44:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:29 +0200
commit7d3e6bee5ba1c6c8059ca8f85fa93962c8549135 (patch)
treee6eee53d1f2afe445ec4b2dbd1f997614e6d87f7
parent899a3ab91073f59ea366f1a0da66e501981145ad (diff)
gnu: rust-rustls-native-certs-0.6: Update to 0.6.3.
* gnu/packages/crates-io.scm (rust-rustls-native-certs-0.6): Update to 0.6.3. [arguments]: Don't skip build. Skip tests. [cargo-inputs]: Replace rust-rustls-pemfile-0.2 with 1. [cargo-development-inputs]: Add rust-rustls-webpki-0.100. Replace rust-rustls-0.20 with 0.21, rust-serial-test-0.5 with 2, rust-webpki-roots-0.22 with 0.23, rust-x509-parser-0.12 with 0.15. Remove rust-webpki-0.22. [native-inputs]: Add perl. Change-Id: I4f4c489252222077c0dfecc3964e2b0663546e64
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d5741f831f..8d4d69929f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66361,32 +66361,31 @@ rustc compiler.")
(define-public rust-rustls-native-certs-0.6
(package
(name "rust-rustls-native-certs")
- (version "0.6.1")
+ (version "0.6.3")
(source
(origin
(method url-fetch)
(uri (crate-uri "rustls-native-certs" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0hq9h3kri19kv00gvbq61h21rarqadxh6y98wj0c2gvxlbgypaaw"))))
+ (base32 "007zind70rd5rfsrkdcfm8vn09j8sg02phg9334kark6rdscxam9"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
+ `(#:tests? #f ; Tests want network access.
#:cargo-inputs
(("rust-openssl-probe" ,rust-openssl-probe-0.1)
- ("rust-rustls-pemfile" ,rust-rustls-pemfile-0.2)
+ ("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
("rust-schannel" ,rust-schannel-0.1)
("rust-security-framework" ,rust-security-framework-2))
#:cargo-development-inputs
(("rust-ring" ,rust-ring-0.16)
- ("rust-rustls" ,rust-rustls-0.20)
- ("rust-serial-test" ,rust-serial-test-0.5)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.100)
+ ("rust-serial-test" ,rust-serial-test-2)
("rust-untrusted" ,rust-untrusted-0.7)
- ("rust-webpki" ,rust-webpki-0.22)
- ("rust-webpki-roots" ,rust-webpki-roots-0.22)
- ("rust-x509-parser" ,rust-x509-parser-0.12))))
+ ("rust-webpki-roots" ,rust-webpki-roots-0.23)
+ ("rust-x509-parser" ,rust-x509-parser-0.15))))
+ (native-inputs (list perl))
(home-page "https://github.com/ctz/rustls-native-certs")
(synopsis "Use the platform native certificate store with rustls")
(description "@code{rustls-native-certs} allows rustls to use the platform