summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-22 22:11:19 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-27 23:05:15 +0000
commit81a417aa3e3f1d619d1bad55c5e30785f376cf9f (patch)
tree18d9408bb87da00cd3225f96899a324bfdc3ba7f
parent5ad619e0dcb89d1d0c608186717efce41081d9b9 (diff)
gnu: Add go-github-com-xhit-go-str2duration-v2.
* gnu/packages/golang-xyz.scm (go-github-com-xhit-go-str2duration-v2): New variable. Change-Id: I30425e498db6dd8cb736eedffe006346973628ed
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2f766fc116..e2b397b04c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2063,6 +2063,31 @@ weighted moving averages}.")
@code{MemoryInfo}.")
(license license:expat)))
+(define-public go-github-com-xhit-go-str2duration-v2
+ (package
+ (name "go-github-com-xhit-go-str2duration-v2")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xhit/go-str2duration")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c9zi9mfy5ww413y1jpfh1rdis43lvd5v6gvajqzh4q1km9lyxjj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xhit/go-str2duration/v2"))
+ (home-page "https://github.com/xhit/go-str2duration")
+ (synopsis "Convert string to duration in golang")
+ (description
+ "This package provides a means to obtain @code{time.Duration} from a
+string. The string can be a string retorned for @code{time.Duration} or a
+similar string with weeks or days too.")
+ (license license:bsd-3)))
+
(define-public go-go-uber-org-automaxprocs
(package
(name "go-go-uber-org-automaxprocs")