summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2022-09-14 15:38:47 -0400
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2022-09-22 10:17:42 +0200
commit81ad759ab96a3bfb9801467b7182af6a2d13159d (patch)
treef8e913fb0f32eba316436224c662491b6173fb90
parent84096a1e843181668df5adac0f58d931c714907a (diff)
gnu: Add tetzle.
* gnu/packages/games.scm (tetzle): New public variable. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
-rw-r--r--gnu/packages/games.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b209a8a584..8d569b013f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2684,6 +2685,35 @@ available, as well as a single-player mode with AI-controlled ships.")
(license (list license:expat ; game
license:silofl1.1)))) ; fonts
+(define-public tetzle
+ (package
+ (name "tetzle")
+ (version "2.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gottcode.org/"
+ name
+ "/"
+ name
+ "-"
+ version
+ "-src.tar.bz2"))
+ (sha256
+ (base32
+ "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (native-inputs (list qttools))
+ (inputs (list qtbase))
+ (home-page "https://gottcode.org/tetzle/")
+ (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
+ (description
+ "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces. Any image
+can be imported and used to create puzzles with a wide range of sizes. Games are
+saved automatically, and you can select between currently in progress games.")
+ (license license:gpl3+)))
+
(define %ufoai-commit "a542a87a891f96b1ab2c44d35b2f6f16859a5019")
(define %ufoai-revision "0")
(define %ufoai-version (git-version "2.6.0_dev" %ufoai-revision %ufoai-commit))