summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-10-23 23:27:24 +0200
committerLudovic Courtès <ludo@gnu.org>2023-10-24 00:02:14 +0200
commit81b293ef34ae495770527354603304e23bc11045 (patch)
tree43980341388e485ce698c25a6294878ff8a0c5d0
parenta1ac534f8a509bc7ddf11bcd5987fa65adf8c9ca (diff)
gnu: kokkos: Restrict builds to 64-bit architectures.
* gnu/packages/cpp.scm (kokkos)[supported-systems]: New field. Change-Id: Ia49e40471e59242e4b40879277a81de022a92d1f
-rw-r--r--gnu/packages/cpp.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d89fcaeb1e..9a02de6334 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1112,6 +1112,10 @@ portable applications targeting all major HPC platforms. For that purpose it
provides abstractions for both parallel execution of code and data management.
Kokkos is designed to target complex node architectures with N-level memory
hierarchies and multiple types of execution resources.")
+
+ ;; Code exhibits integer size mismatches when compiled on 32-bit systems.
+ (supported-systems %64bit-supported-systems)
+
(license license:asl2.0))) ; With LLVM exception
(define-public tweeny