summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-22 22:43:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commit81f7f29752525bfe3395036fb94fa059c95893f2 (patch)
treefd7bf2399e5adb16db3b1565c4fb8d014c07f9f7
parent8f0cc2ffce9ebf013a6fd3696e096517123ee935 (diff)
gnu: Add python-rauth.
* gnu/packages/python.scm (python-rauth, python2-rauth): New variables.
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8e0019eb43..0c3df3b296 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7085,6 +7085,39 @@ Python at your fingertips, in Lisp form.")
(define-public python2-hy
(package-with-python2 python-hy))
+(define-public python-rauth
+ (package
+ (name "python-rauth")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rauth" version))
+ (sha256
+ (base32
+ "00pq7zw429hhza9c0qzxiqp77m653jv09z92nralnmzwdf6pzicf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "check"))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page "https://github.com/litl/rauth")
+ (synopsis "Python library for OAuth 1.0/a, 2.0, and Ofly")
+ (description
+ "Rauth is a Python library for OAuth 1.0/a, 2.0, and Ofly. It also
+provides service wrappers for convenient connection initialization and
+authenticated session objects providing things like keep-alive.")
+ (license license:expat)))
+
+(define-public python2-rauth
+ (let ((rauth (package-with-python2 python-rauth)))
+ (package (inherit rauth)
+ (native-inputs
+ `(("python2-unittest2", python2-unittest2)
+ ,@(package-native-inputs rauth))))))
+
(define-public python-futures
(package
(name "python-futures")