summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 13:00:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 13:01:04 +0300
commit830a47e85d3282c54d5d8e7b79afd7efd96919ec (patch)
treed754502a1b53e21494eb6c0bcdd4610c66d6ef85
parent60c9828933252faf4d32b9fe11f34558f58f5603 (diff)
gnu: python-flask: Honor #:tests in check phase.
* gnu/packages/python-web.scm (python-flask)[arguments]: Honor #:tests flag.
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fdc3aa5c51..10f38d8777 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2943,8 +2943,9 @@ minimum of WSGI.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv" "tests"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(propagated-inputs