summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-29 21:55:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-05 20:33:36 +0100
commit8344007781d013f4a714e924be8072dc513c69bd (patch)
tree49357450c4ca4779d6c1fceff5a4edfadf931dcc
parent28d1e51b30a4ed6c3d7b4f05070be30147c0be45 (diff)
gnu: emacs-embark: Update to 0.18.
* gnu/packages/emacs-xyz.scm (emacs-embark): Update to 0.18.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 23 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4dd813f919..a06469662e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9872,25 +9872,28 @@ them easier to distinguish from other, less important buffers.")
(license license:expat)))
(define-public emacs-embark
- (package
- (name "emacs-embark")
- (version "0.17")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/embark")
- (commit version)))
- (sha256
- (base32 "1s0ssf4q9kg4c5w87h2ypyvrhi31mz3s6k4h7pxi9a47lkccq8n1"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-avy emacs-consult))
- (home-page "https://github.com/oantolin/embark")
- (synopsis "Emacs mini-buffer actions rooted in keymaps")
- (description
- "This package provides a sort of right-click contextual menu for Emacs
+ ;; XXX: Upstream did not tag last release. Use commit matching version
+ ;; bump.
+ (let ((commit "09da327d43793f0b30114ee80d82ef587124462a"))
+ (package
+ (name "emacs-embark")
+ (version "0.18")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/embark")
+ (commit commit)))
+ (sha256
+ (base32 "0drzsa9rzjy0548pa161cf1d71lnyjri31rkwyjray9gy2adbnhv"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-avy emacs-consult))
+ (home-page "https://github.com/oantolin/embark")
+ (synopsis "Emacs mini-buffer actions rooted in keymaps")
+ (description
+ "This package provides a sort of right-click contextual menu for Emacs
offering you relevant @emph{actions} to use on a @emph{target} determined by
the context.
@@ -9904,7 +9907,7 @@ get offered actions like deleting, copying, renaming, visiting in another
window, running a shell command on the file, etc. For buffers the actions
include switching to or killing the buffer. For package names the actions
include installing, removing or visiting the homepage.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-prescient
(package