summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-09-18 06:35:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-18 10:36:24 +0200
commit83598dafb971fda9206f14cf46d072e04e27fd43 (patch)
tree0edc8436ef69ef8be66d1e70382f6db458791968
parent1c8e159335c3723194cd0e5357c89abb8d4edf13 (diff)
gnu: python-fit-nbinom: Remove syntax error in setup.py.
* gnu/packages/python-xyz.scm (python-fit-nbinom)[arguments]: Add phase 'remove-invalid-syntax. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dd3f987475..e96f4a2d0d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -582,6 +582,14 @@ and variables you'll need already imported and created.
(base32
"12v8l5i35vjbpvh5i4lw29ys6vpr3z7pysyrx33hxaq09zr015mx"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'remove-invalid-syntax
+ (lambda _
+ (substitute* "setup.py"
+ ((".\\*\"") "\"")))))))
(propagated-inputs (list python-numpy python-scipy))
(home-page "https://github.com/joachimwolff/fit_nbinom")
(synopsis "Negative binomial maximum likelihood estimator")