summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-19 20:47:01 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-19 20:53:33 +0100
commit8523d79ff5ea6577693e21577dbeab4e8f57481d (patch)
tree4bb49f460516e40b1178cf233be88923aa8bebd3
parent4eebb73295a8ffdaefcfb7940254ad9c18e4e5d4 (diff)
gnu: python-attrdict: Replace by python-attrdict3.
* gnu/packages/python-xyz.scm (python-attrdict): Replace by... (python-attrdict3): ...this. * gnu/packages/wxwidgets.scm (python-wxpython)[native-inputs]: Swap packages.
-rw-r--r--gnu/packages/python-xyz.scm14
-rw-r--r--gnu/packages/wxwidgets.scm3
2 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2f1a9aed0..6181957d44 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016, 2019, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2017, 2021, 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -19908,21 +19908,21 @@ from the header, as well as section details and data available.")
and bit flag values.")
(license license:expat)))
-(define-public python-attrdict
+(define-public python-attrdict3
(package
- (name "python-attrdict")
- (version "2.0.1")
+ (name "python-attrdict3")
+ (version "2.0.2")
(source (origin
(method url-fetch)
- (uri (pypi-uri "attrdict" version))
+ (uri (pypi-uri "attrdict3" version))
(sha256
(base32
- "0w3vsz64j9npxfgh83hghsh161wwkrx1fxqi1533js2wnnc0dj9m"))))
+ "1s2z6c9jam5azm746l49wsqsyi29zbbrknq1axsw230jl4f1fk00"))))
(build-system python-build-system)
;; The package is no longer maintained and tests need some work.
(arguments '(#:tests? #f))
(propagated-inputs (list python-six))
- (home-page "https://github.com/bcj/AttrDict")
+ (home-page "https://github.com/pirofti/AttrDict3")
(synopsis "Attribute-style access dictionaries")
(description
"This package provides mapping objects whose elements can be accessed
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 0183e07c31..0eaebc1068 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -309,7 +310,7 @@ and many other languages.")
(native-inputs
(list pkg-config python-waf))
(propagated-inputs
- (list python-attrdict python-numpy python-pillow python-six))
+ (list python-attrdict3 python-numpy python-pillow python-six))
(home-page "https://wxpython.org/")
(synopsis "Cross platform GUI toolkit for Python")
(description "wxPython is a cross-platform GUI toolkit for the Python