summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-04 21:03:59 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-05-31 10:45:53 +0200
commit85d80283b6d14b19dacdd687590eba494da4864f (patch)
treebc24bc43500419ea5952d051250d3961de897cff
parentc7f023723c1de3f82a3abfa47b8366fccbd3540a (diff)
gnu: pep-engine: Update to 2.1.34.
* gnu/packages/pep.scm (fdik-libetpan): Update to current development version. [source]: Switch to pep.foundation. (pep-engine): Update to 2.1.34. [source]: Switch to new git repo. [arguments]<make-flags>: Enable release-build. [inputs]: Use normal sequoia. * gnu/packages/sequoia.scm (sequoia4pEp): Remove variable.
-rw-r--r--gnu/packages/pep.scm27
-rw-r--r--gnu/packages/sequoia.scm75
2 files changed, 14 insertions, 88 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index 6d24534f7e..6ee01b9df5 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -65,9 +65,9 @@ shell provides options to redirect the output into a pipe or a file.")
(define fdik-libetpan
;; pEp Engine requires libetpan with a set of patches that have not been
;; upstreamed yet.
- (let ((commit "210ba2b3b310b8b7a6ee4a4e35e50f7fa379643f") ; 2020-06-03
- (checksum "00000nij3ray7nssvq0lzb352wmnab8ffzk7dgff2c68mvjbh1l6")
- (revision "5"))
+ (let ((commit "0b80c39dd1504462ba3a39dc53db7c960c3a63f3") ; 2020-11-27
+ (checksum "0gv3ivaziadybjlf6rfpv1j5z5418243v5cvl4swlxd2njsh7gjk")
+ (revision "6"))
(package
(inherit libetpan)
(name "fdik-libetpan")
@@ -77,7 +77,7 @@ shell provides options to redirect the output into a pipe or a file.")
(inherit (package-source libetpan))
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fdik/libetpan")
+ (url "https://gitea.pep.foundation/pEp.foundation/libetpan")
(commit commit)))
(file-name (string-append name "-" version))
(sha256 (base32 checksum)))))))
@@ -85,23 +85,24 @@ shell provides options to redirect the output into a pipe or a file.")
(define-public pep-engine
(package
(name "pep-engine")
- (version "2.0.6")
+ (version "2.1.34")
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://pep.foundation/dev/repos/pEpEngine")
- (changeset "ebb62ba262dd"))) ;; r4721
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.pep.foundation/pEp.foundation/pEpEngine")
+ (commit (string-append "Release_" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0ljf79j4ng7l8w6pbdcrfzb4yk51zslypvq0n72ib1d7grqvnagi"))))
+ (base32 "00q96y9j985qfa382acsz02i0zf6ayq2gmg8z70jzl04isg1h3cn"))))
(build-system gnu-build-system)
(arguments
'(#:parallel-build? #f
+ #:make-flags '("NDEBUG=1") ; release build
#:phases
(modify-phases %standard-phases
(replace 'configure
- ;; pEpEngie does not use autotools and configure,
+ ;; pEpEngine does not use autotools and configure,
;; but a local.conf. We need to tweak the values there.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -132,7 +133,7 @@ OPENPGP=SEQUOIA
("libiconv" ,libiconv)
("nettle" ,nettle)
("openssl" ,openssl)
- ("sequoia" ,sequoia4pEp)
+ ("sequoia" ,sequoia)
("sqlite3" ,sqlite)
("util-linux" ,util-linux "lib"))) ;; uuid.h
(home-page "https://pep.foundation/")
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index c83926ef6c..2c68f43e36 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -218,78 +218,3 @@
several crates, providing both a low-level and a high-level API for dealing
with OpenPGP data.")
(license license:gpl2+)))
-
-(define-public sequoia4pEp
- ;; Currently pEp Engine requires sequoia in not-so-current version
- (package
- (inherit sequoia)
- (name "sequoia")
- (version "0.15.0-pEp")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit "0eb1b6cd846ea8c36b3dfdf01ec88383fc64f2fe")))
- (sha256
- (base32 "06dqs9whwp9lfibwp8dqm0aw4nm3s3v4jp2n4fz51zcvsld40nfh"))
- (file-name (git-file-name name version))))
- (arguments
- (substitute-keyword-arguments (package-arguments sequoia)
- ((#:cargo-inputs _)
- `(("rust-anyhow" ,rust-anyhow-1)
- ("rust-base64" ,rust-base64-0.11)
- ("rust-bzip2" ,rust-bzip2-0.3)
- ("rust-capnp" ,rust-capnp-0.10)
- ("rust-capnp-rpc" ,rust-capnp-rpc-0.10)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-crossterm" ,rust-crossterm-0.13)
- ("rust-dirs" ,rust-dirs-2)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-fs2" ,rust-fs2-0.4)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-http" ,rust-http-0.1)
- ("rust-hyper" ,rust-hyper-0.12)
- ("rust-hyper-tls" ,rust-hyper-tls-0.3)
- ("rust-idna" ,rust-idna-0.2)
- ("rust-itertools" ,rust-itertools-0.8)
- ("rust-lalrpop" ,rust-lalrpop-0.17)
- ("rust-lalrpop-util" ,rust-lalrpop-util-0.17)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-memsec" ,rust-memsec-0.5)
- ("rust-native-tls" ,rust-native-tls-0.2)
- ("rust-nettle" ,rust-nettle-7)
- ("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-quote" ,rust-quote-1)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-regex" ,rust-regex-1)
- ("rust-rpassword" ,rust-rpassword-4)
- ("rust-rusqlite" ,rust-rusqlite-0.19)
- ("rust-sha2" ,rust-sha2-0.8)
- ("rust-syn" ,rust-syn-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-0.1)
- ("rust-tokio-core" ,rust-tokio-core-0.1)
- ("rust-tokio-io" ,rust-tokio-io-0.1)
- ("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
- ("rust-url" ,rust-url-2)
- ("rust-zbase32" ,rust-zbase32-0.1)))
- ((#:cargo-development-inputs _)
- `(("rust-assert-cli" ,rust-assert-cli-0.6)
- ("rust-colored" ,rust-colored-1)
- ("rust-filetime" ,rust-filetime-0.2)))
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'unpin-deps
- (lambda _
- (substitute* (find-files "." "Cargo.toml")
- (("= \"<") "= \"")
- (("= \"=") "= \""))
- #t))))))
- (properties `((hidden? . #t)))))