summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-27 09:36:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-29 14:09:23 -0400
commit868113126c89ecb7f928c49de893122fa0fe272c (patch)
treee02f1d5b83d2132090366a0772a98605ca7e352a
parentebf5d77eab148394c6db0dd135ea119ca377aaed (diff)
build: Have the release target depend on 'all'.
Otherwise, the scripts/guix wrapper may not be present, which would cause the user's guix wrapper to be used, which in turn would manipulate GUILE_LOAD_PATH in a way that would cause its Guix modules to take precedence over those of the tree, with confusion ensuing. * Makefile.am (release): Add 'all' as a prerequisite.
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ab03dfab2c..8d059eb033 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -839,7 +839,7 @@ system_flags = $(foreach system,$(1),-s $(system))
#
# XXX: Depend on 'dist' rather than 'distcheck' to work around the Gettext
# issue described at <https://savannah.gnu.org/bugs/index.php?51027>.
-release: dist-with-updated-version
+release: dist-with-updated-version all
cd po; git checkout .
@if ! git diff-index --quiet HEAD; then \
echo "There are uncommitted changes; stopping." >&2 ; \