summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-27 14:55:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-27 15:37:33 +0200
commit86d316b3346eac29c7e466f66b4422067c1cdb96 (patch)
tree5f77ccc53cd26c8f4cbd309eef4f65da61846a5e
parenta4b4dc8f9975ec484b27c33d940cfeea8e9fdc85 (diff)
gnu: tla2tools: Build from a known commit.
Reported by Andrew Patterson <andrewpatt7@gmail.com>. * gnu/packages/java.scm (tla2tools)[version, source]: Use a commit (and GIT-VERSION) instead of a tag.
-rw-r--r--gnu/packages/java.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 621a6fe914..a404250d38 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -14091,16 +14091,21 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
license:asl2.0))))
(define-public tla2tools
- (let* ((version "1.8.0")
- (tag (string-append "v" version)))
+ ;; This package was originally based on the "v1.8.0" tag, but that merely
+ ;; points to the moving master branch. That might be because the ‘latest
+ ;; release’ at GitHub is currently 1.7.1. We'll see! For now, rather than
+ ;; downgrade to 1.7.1 proper, use the commit that we originally dubbed 1.8.0.
+ (let* ((release "1.7.1")
+ (revision "0")
+ (commit "6932e19083fc6df42473464857fc1280cb5aaecc"))
(package
(name "tla2tools")
- (version version)
+ (version (git-version release revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/tlaplus/tlaplus")
- (commit tag)))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
@@ -14124,7 +14129,7 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
#:make-flags '("-f" ,build-xml)
#:phases
(modify-phases %standard-phases
- ;; Replace packed libs with references to jars in store
+ ;; Replace packed libs with references to jars in store
(add-after 'unpack 'replace-libs
(lambda* (#:key inputs #:allow-other-keys)
(define (input-jar input)
@@ -14147,12 +14152,12 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
("junit-4.12.jar" . "java-junit")
("easymock-3.3.1.jar" . "java-easymock")))
;; Retain a tiny subset of the original X-Git-*
- ;; manifest values just to aid in debugging
+ ;; manifest values just to aid in debugging.
(substitute* ,build-xml
- (("\\$\\{git.tag\\}") ,tag))))
+ (("\\$\\{git.tag\\}") (string-append "v" ,release)))))
(add-before 'check 'prepare-tests
(lambda _
- ;; pcal tests write to cfg files
+ ;; The pcal tests write to .cfg files.
(for-each (cut chmod <> #o644)
(find-files (string-append ,tlatools
"/test-model/pcal")