summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:35:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:54 +0200
commit8713eebf69d7da4e47d3a4cb98839f22646bd5ef (patch)
treeb93ae458dff7a7e8d204162676454f9cf98e359c
parent21f2977a5c10e9649ad75e5a104ae7ee506d30ef (diff)
gnu: Add texlive-web.
* gnu/packages/tex.scm (texlive-web): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14b4bc44f8..eb837a4c6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8341,6 +8341,30 @@ diagrams for lectures or assignment sheets.")
per command or per parameter.")
(license license:gpl3+)))
+(define-public texlive-web
+ (package
+ (name "texlive-web")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/tangle.1"
+ "doc/man/man1/tangle.man1.pdf"
+ "doc/man/man1/weave.1"
+ "doc/man/man1/weave.man1.pdf")
+ (base32
+ "0iiyzzrgwakw7ipdnwmjwcrqayzq4yn4786zlr9zirmmj34hpamz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-kpathsea))
+ (home-page "https://ctan.org/pkg/web")
+ (synopsis "Original literate programming system")
+ (description
+ "The system processes web files in two ways: firstly to rearrange them to
+produce compilable code (using the program @command{tangle}), and secondly to
+produce a TeX source (using the program @command{weave}) that may be typeset
+for comfortable reading.")
+ (license license:knuth)))
+
(define-public texlive-wheelchart
(package
(name "texlive-wheelchart")