summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-16 11:02:14 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:42 +0200
commit88563b71c70ff42168771402b2820f01ccd02420 (patch)
tree99c0b5292953567e172c3d3971d7872911b82129
parent42f13265355c60a5e3c0420b80ae4dad9074d0b4 (diff)
gnu: Add python-aspectlib.
* gnu/packages/python-xyz.scm (python-aspectlib): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fd4eef5d9c..7142d5a294 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27581,3 +27581,25 @@ It implements advanced Python dictionaries with dot notation access.")
(synopsis "Python container class boilerplate killer")
(description "Avoid repetetive boilerplate code in Python classes.")
(license license:bsd-3)))
+
+(define-public python-aspectlib
+ (package
+ (name "python-aspectlib")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aspectlib" version))
+ (sha256
+ (base32 "1am4ycf292zbmgz791z393v63w7qrynf8q5p9db2wwf2qj1fqxfj"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-fields" ,python-fields)))
+ (home-page "https://github.com/ionelmc/python-aspectlib")
+ (synopsis
+ "Python monkey-patching and decorators")
+ (description
+ "This package provides an aspect-oriented programming, monkey-patch
+and decorators library. It is useful when changing behavior in existing
+code is desired. It includes tools for debugging and testing:
+simple mock/record and a complete capture/replay framework.")
+ (license license:bsd-2)))