summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-06 15:39:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-06 16:37:16 +0200
commit88ff6feca12b85fd366fd2db1f0209818769a91e (patch)
tree8740ccc4da4655a63c2737b57d77cca9b5ed9908
parent9d4339afb16af0f057b8a8afe8da443c33fb63e1 (diff)
gnu: Add r-webchem.
* gnu/packages/cran.scm (r-webchem): New variable.
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index af5749b0d0..e161088613 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9381,6 +9381,40 @@ of merit, ordering functions, and enhanced versions of @code{pairs} and
@code{parcoord} which color panels according to their merit level.")
(license license:gpl2+)))
+(define-public r-webchem
+ (package
+ (name "r-webchem")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "webchem" version))
+ (sha256
+ (base32 "06b9i9jipg564zyw4gkgiidz7501rlp40hxm4z3k5mzy148lr5vq"))))
+ (properties `((upstream-name . "webchem")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-base64enc
+ r-data-tree
+ r-dplyr
+ r-httr
+ r-jsonlite
+ r-purrr
+ r-rlang
+ r-rvest
+ r-stringr
+ r-tibble
+ r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://docs.ropensci.org/webchem/")
+ (synopsis "Chemical information from the web")
+ (description
+ "This package interacts with a suite of web services for chemical
+information. Sources include: Alan Wood's Compendium of Pesticide Common
+Names, Chemical Identifier Resolver, ChEBI, Chemical Translation Service,
+ChemSpider, ETOX, Flavornet, NIST Chemistry WebBook, OPSIN, PubChem, SRS,
+Wikidata.")
+ (license license:expat)))
+
(define-public r-webshot
(package
(name "r-webshot")