summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-12-02 16:08:01 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-19 23:49:37 +0100
commit89f79f7129ddfa4140f32440de369afa499025f4 (patch)
treeb682d9ee45e065f12b757a0cf546d23dea6e7d94
parent030018f923487791951ce59efe4f80a06bc73d18 (diff)
gnu: libsoup-minimal: Update to 3.4.4.
The option to build documentation has changed between libsoup 2 and libsoup 3. The failing socket test has been moved to a different file. libsoup-minimal-2 introduces a new phase to disable tests, however the 'adjust-tests phase of libsoup-minimal must be removed. For simplicity, we use the 'adjust-tests name for the phase of all variants. * gnu/packages/gnome.scm (libsoup-minimal): Update to 3.4.4. [#:configure-flags]: Change name of docs option. [#:phases]<adjust-tests>: Change the file name of socket test. (libsoup-minimal-2) [arguments]: Override #:configure-flags. [#:phases]: Override 'adjust-tests. (libsoup) [version]: Remove field. [source]: Remove field. [#:configure-flags]: Replace -Ddocs=disabled with -Ddocs=enabled. Change-Id: Iace1bf0f1d805a0eed7e484a7cd496ac04631b32 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 12 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4da80c67bb..38ed25a5e4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5021,7 +5021,7 @@ as OpenStreetMap, OpenCycleMap, OpenAerialMap and Maps.")
(define-public libsoup-minimal
(package
(name "libsoup-minimal")
- (version "3.0.7")
+ (version "3.4.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -5029,17 +5029,17 @@ as OpenStreetMap, OpenCycleMap, OpenAerialMap and Maps.")
"libsoup-" version ".tar.xz"))
(sha256
(base32
- "1j7p3cz6hwi9js9rp0pbas7cdln97yg9v2l1nv5imhcr6p7r1pzb"))))
+ "1an5n2sa70f40my4g20lk38s5ib99c32bzzg8gm91v9nbxr6f719"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dgtk_doc=false")
+ `(#:configure-flags '("-Ddocs=disabled")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'adjust-tests
(lambda _
;; This test fails due to missing /etc/nsswitch.conf
;; in the build environment.
- (substitute* "tests/socket-test.c"
+ (substitute* "tests/unix-socket-test.c"
((".*/sockets/unconnected.*") ""))
;; These fail because "subdomain.localhost" does not resolve in
@@ -5095,9 +5095,13 @@ and the GLib main loop, to integrate well with GNOME applications.")
"04rgv6hkyhgi7lak9865yxgbgky6gc635p7w6nhcbj64rx0prdz4"))))
(arguments
(substitute-keyword-arguments (package-arguments libsoup-minimal)
+ ((#:configure-flags configure-flags)
+ ;; The option name changed between libsoup 2 and libsoup 3.
+ #~(cons "-Dgtk_doc=false"
+ (delete "-Ddocs=disabled" #$configure-flags)))
((#:phases phases)
`(modify-phases ,phases
- (add-after 'unpack 'disable-failing-tests
+ (replace 'adjust-tests
(lambda _
;; Disable the SSL test, failing since 2.68 and resolved in
;; libsoup 3.
@@ -5110,20 +5114,13 @@ and the GLib main loop, to integrate well with GNOME applications.")
(define-public libsoup
(package/inherit libsoup-minimal
(name "libsoup")
- (version "3.4.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/libsoup/"
- (version-major+minor version) "/"
- "libsoup-" version ".tar.xz"))
- (sha256
- (base32
- "1an5n2sa70f40my4g20lk38s5ib99c32bzzg8gm91v9nbxr6f719"))))
(outputs (cons "doc" (package-outputs libsoup-minimal)))
(arguments
(substitute-keyword-arguments (package-arguments libsoup-minimal)
((#:configure-flags configure-flags)
- #~(delete "-Dgtk_doc=false" #$configure-flags))
+ #~(cons "-Ddocs=enabled"
+ ;; The default value is 'auto', meaning it could be skipped.
+ (delete "-Ddocs=disabled" #$configure-flags)))
((#:phases phases)
#~(modify-phases #$phases
(replace 'adjust-tests