summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <csantosb@inventati.org>2024-03-09 12:02:58 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-03-13 09:47:27 +0100
commit8bd8484e6da4f3665432615b09eef5459d381ed9 (patch)
treee7c40b6db5a7dfec81a822f48ed488717ca46d87
parentf0d5d50c2c6f16b98c4f1acce1ff71f142d595ee (diff)
gnu: emacs-org-pandoc-import: Update to 1.0-0.db308f1.
* gnu/packages/emacs-xyz.scm (emacs-org-pandoc-import): Update to 1.0-0.db308f1. Last stable 1.0 version dates back from 3 years ago. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Ic0da2b7956695f75274aab14a13dbfca919a4999
-rw-r--r--gnu/packages/emacs-xyz.scm63
1 files changed, 33 insertions, 30 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5810455d0b..eb3e21968c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11287,41 +11287,44 @@ Features degrade gracefully when viewed from terminal.")
(license license:gpl3+)))
(define-public emacs-org-pandoc-import
- (package
- (name "emacs-org-pandoc-import")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tecosaur/org-pandoc-import/")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "00z9bpm975mlyqlxbyib3j547br6kvcam04b70qkmq22vh8yf341"))))
- (build-system emacs-build-system)
- (arguments
- `(#:include
- (cons* "^filters\\/" "^preprocessors" %default-include)
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((pandoc (assoc-ref inputs "pandoc")))
- (substitute* "org-pandoc-import.el"
- (("\"pandoc\"") (string-append "\"" pandoc "/bin/pandoc\"")))))))))
- (inputs
- (list pandoc))
- (home-page "https://github.com/tecosaur/org-pandoc-import/")
- (synopsis "Read and edit non-Org file types in Org")
- (description
- "This package uses Pandoc to convert selected file types to Org. It can
+ (let ((commit "db308f1a05be26ce5b287633637ce554599b1377")
+ (revision "0"))
+ (package
+ (name "emacs-org-pandoc-import")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tecosaur/org-pandoc-import/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19z1qaairhpj8kyyqwx8yf53j3f03a9a1z1jfa348qmncnra5jmh"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include
+ (cons* "^filters\\/" "^preprocessors" %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((pandoc (assoc-ref inputs "pandoc")))
+ (substitute* "org-pandoc-import.el"
+ (("\"pandoc\"")
+ (string-append "\"" pandoc "/bin/pandoc\"")))))))))
+ (inputs
+ (list pandoc))
+ (home-page "https://github.com/tecosaur/org-pandoc-import/")
+ (synopsis "Read and edit non-Org file types in Org")
+ (description
+ "This package uses Pandoc to convert selected file types to Org. It can
convert supported non-Org files to an Org file with Pandoc.
It can also intercept requests for non-Org files it knows it can convert,
convert the file to a temporary Org file, and open this file instead. On
save, it exports back to the original non-Org file.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-pomodoro
;; Last release version was from 2016.