summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:57 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:54 +0000
commit8ca17c042622220c54491ae616812bc199a2f2b9 (patch)
tree426b01d64b407e751b820b82d7261ff109deb6fd
parent9770402a92585f5af15264aacf8718e7f594102c (diff)
gnu: Add ocaml-mirage-runtime.
* gnu/packages/ocaml.scm (ocaml-mirage-runtime): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 38d581682b..40ef5c27e2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3708,6 +3708,27 @@ according RFC2047.")
"This is the runtime support library for code generated by functoria.")
(license license:isc)))
+(define-public ocaml-mirage-runtime
+ (package
+ (inherit ocaml-functoria-runtime)
+ (name "ocaml-mirage-runtime")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "mirage-runtime"
+ ;; TODO again, wants opam, other tests seem to pass
+ ;; look for a way to disable tests that want network access
+ #:tests? #f))
+ (propagated-inputs (list ocaml-ipaddr ocaml-functoria-runtime ocaml-fmt
+ ocaml-logs ocaml-lwt))
+ (native-inputs (list ocaml-alcotest))
+ (home-page "https://github.com/mirage/mirage")
+ (synopsis
+ "The base MirageOS runtime library, part of every MirageOS unikernel")
+ (description
+ "This package provides a bundle of useful runtime functions for
+applications built with MirageOS")
+ (license license:isc)))
+
(define-public ocaml-ocurl
(package
(name "ocaml-ocurl")