summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-09-11 07:09:21 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-09-11 16:43:31 +0200
commit8efed18128b8bda3d7e4db460998dc20e3d6dc2f (patch)
treef945e011408088e4e313d062ab2ebdaa5272b951
parent399fae26af4d9166decb2b1667a1ac06df02f370 (diff)
gnu: java-slf4j-api: Update the source URI.
* gnu/packages/java.scm (java-slf4j-api)[source]: Replace the URI with "git-reference" to GitHub as the origin reference to "https://www.slf4j.org/dist/slf4j-..." seems to be broken. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/java.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index bb172f3bee..0ad7af67dd 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -8065,12 +8065,14 @@ more efficient storage-wise than an uncompressed bitmap (as implemented in the
(name "java-slf4j-api")
(version "1.7.25")
(source (origin
- (method url-fetch)
- (uri (string-append "https://www.slf4j.org/dist/slf4j-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/qos-ch/slf4j")
+ (commit (string-append "v_" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13j51sgzmhhdrfa74gkal5zpip7r1440dh7zsi2c8bpb2zs1v8kb"))
+ "15n42zq3k1iyn752nwdcbs44hxns2rmxhglwjfr4np7lxx56apjl"))
(modules '((guix build utils)))
;; Delete bundled jars.
(snippet