summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-23 16:37:02 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:09 +0200
commit91154d4a40321dc1fa3cdd53cad407af539261be (patch)
tree164d08d872f1652122b9333be2385c05d7ab15d2
parentc009e934512acf82aa2e3a7bda7765039afe4d9a (diff)
gnu: Add python-fakeredis.
* gnu/packages/python.scm (python-fakeredis, python2-fakeredis): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bee94b42e2..4082632679 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14592,3 +14592,31 @@ parsing code in hiredis. It primarily speeds up parsing of multi bulk replies."
(define-public python2-hiredis
(package-with-python2 python-hiredis))
+
+(define-public python-fakeredis
+ (package
+ (name "python-fakeredis")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fakeredis" version))
+ (sha256
+ (base32
+ "0zncahj3byyasyfx9i7k991ph0n0lq8v3a21pqri5qxn9564bk9r"))))
+ (build-system python-build-system)
+ (arguments
+ ;; no tests
+ `(#:tests? #f))
+ (home-page "https://github.com/jamesls/fakeredis")
+ (synopsis "Fake implementation of redis API for testing purposes")
+ (description "Fakeredis is a pure python implementation of the redis-py
+python client that simulates talking to a redis server. This was created for a
+single purpose: to write unittests. Setting up redis is not hard, but many time
+ you want to write unittests that do not talk to an external server (such as
+redis). This module now allows tests to simply use this module as a reasonable
+substitute for redis.")
+ (license license:bsd-3)))
+
+(define-public python2-fakeredis
+ (package-with-python2 python-fakeredis))