summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-03-21 16:05:23 +0000
committerLudovic Courtès <ludo@gnu.org>2023-04-17 23:50:42 +0200
commit92d49c8cd81a3345f097817adfbae570a6b1f8e9 (patch)
treeeac3284baff5ef44bd19150bde256952fcc3e281
parenta718f5f55bd005a93d1969238043776ead33d89e (diff)
gnu: usbutils: Use G-Expressions.
* gnu/packages/linux.scm (usbutils): Use G-Expressions. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b3660c3eeb..401536685b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2379,23 +2379,22 @@ slabtop, tload, top, vmstat, w, watch and sysctl.")
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap-scripts
- (lambda _
- (substitute* "usbhid-dump/bootstrap"
- (("/bin/sh") (which "sh")))))
- (add-after 'install 'separate-python-output
- ;; Separating one Python script shaves more than 106 MiB from :out.
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (out:python (assoc-ref outputs "python")))
- (for-each (lambda (file)
- (let ((old (string-append out "/" file))
- (new (string-append out:python "/" file)))
- (mkdir-p (dirname new))
- (rename-file old new)))
- (list "bin/lsusb.py"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'patch-bootstrap-scripts
+ (lambda _
+ (substitute* "usbhid-dump/bootstrap"
+ (("/bin/sh") (which "sh")))))
+ (add-after 'install 'separate-python-output
+ ;; Separating one Python script shaves more than 106 MiB from :out.
+ (lambda _
+ (for-each (lambda (file)
+ (let ((old (string-append #$output "/" file))
+ (new (string-append #$output:python "/" file)))
+ (mkdir-p (dirname new))
+ (rename-file old new)))
+ (list "bin/lsusb.py")))))))
(inputs
(list eudev libusb python))
(native-inputs