summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-13 18:51:01 +0100
committerLeo Famulari <leo@famulari.name>2016-12-13 17:04:19 -0500
commit97be1bc23128cf42c49867d984c43f6fea3820d6 (patch)
tree252c48edca5534cc95cf163d5da8305cf2b2e3fc
parent3fe2c209e0e69660164b5484a2d9f9d946006e36 (diff)
gnu: python-click: Fix tests.
* gnu/packages/python.scm (python-click, python2-click)[arguments]: Replace 'check' with custom phase. [native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 28ead167d8..1a8a9a407c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2301,7 +2301,12 @@ is used by the Requests library to verify HTTPS requests.")
(substitute* "click/_unicodefun.py"
(("'locale'")
(string-append "'" glibc "/bin/locale'"))))
- #t)))))
+ #t))
+ (replace 'check
+ (lambda _
+ (zero? (system* "make" "test")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "http://click.pocoo.org")
(synopsis "Command line library for Python")
(description