summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-12-30 20:25:50 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-06 15:58:56 +0100
commit9891dd881489be65980f326d87ca580c0001c778 (patch)
tree3bf3eb69115c8a8bcdd1e6b91c4c8c20bd9117cb
parente994bc0abf39db228fa61f1aaf24840c19c47647 (diff)
gnu: Add qcheckers.
* gnu/packages/games.scm (qcheckers): New variable. Change-Id: I399ac6aa0c268a8fcf68aabe716fe2d2d5e42605 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/games.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8117886583..4a2b2fd832 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -79,6 +79,7 @@
;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10115,6 +10116,36 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(home-page "https://github.com/bernds/q5Go")
(license license:gpl2+)))
+(define-public qcheckers
+ (package
+ (name "qcheckers")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/portnov/qcheckers")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05wzql6abzdf6l0vdzki4rfy2zn31mcplh1wkw3ddk8w81pvaymw"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "qmake"
+ (string-append "PREFIX=" #$output)))))))
+ (inputs (list qtbase-5 qtsvg-5))
+ (home-page "https://portnov.github.io/qcheckers/")
+ (synopsis "Qt-based checkers boardgame")
+ (description "QCheckers, formely known as KCheckers, is a is a Qt version
+of the classic boardgame checkers (also known as draughts).")
+ (license license:gpl2+)))
+
(define-public xmoto
(package
(name "xmoto")