summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 15:21:06 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-28 16:27:36 +0100
commit995151b7ed4be160e2d815476eb1e6940359a253 (patch)
tree746ac358e07578f220c6a12dd1972669dcdafbd2
parent3bc07d1feb3eb57abd1dd97ef3c17c406511dc5e (diff)
gnu: go-github-com-mgutz-ansi: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mgutz-ansi): Move from here... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ic0e6a1400da75f8ef3c663e1ed10ff51408480f6
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fcb352148c..46468a5bb6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2212,6 +2212,34 @@ the @code{cpan} module @code{Parse::CommandLine}.")
other directories. It is optimized for filewalking.")
(license license:expat)))
+(define-public go-github-com-mgutz-ansi
+ (let ((commit "9520e82c474b0a04dd04f8a40959027271bab992")
+ (revision "0"))
+ (package
+ (name "go-github-com-mgutz-ansi")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/mgutz/ansi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00bz22314j26736w1f0q4jy9d9dfaml17vn890n5zqy3cmvmww1j"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/mgutz/ansi"))
+ (native-inputs
+ (list go-github-com-mattn-go-isatty go-github-com-mattn-go-colorable))
+ (home-page "https://github.com/mgutz/ansi")
+ (synopsis "Small, fast library to create ANSI colored strings and codes")
+ (description
+ "This package provides @code{ansi}, a Go module that can generate ANSI
+colored strings.")
+ (license license:expat))))
+
(define-public go-github-com-miekg-dns
(package
(name "go-github-com-miekg-dns")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 269bcaa3e4..4de36a3199 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4289,34 +4289,6 @@ The yaml package supports most of YAML 1.2, but preserves some behavior from
(description "This package provides a Golang Matrix client.")
(license license:asl2.0)))
-(define-public go-github-com-mgutz-ansi
- (let ((commit "9520e82c474b0a04dd04f8a40959027271bab992")
- (revision "0"))
- (package
- (name "go-github-com-mgutz-ansi")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url
- "https://github.com/mgutz/ansi")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "00bz22314j26736w1f0q4jy9d9dfaml17vn890n5zqy3cmvmww1j"))))
- (build-system go-build-system)
- (native-inputs
- (list go-github-com-mattn-go-isatty go-github-com-mattn-go-colorable))
- (arguments
- '(#:import-path "github.com/mgutz/ansi"))
- (home-page "https://github.com/mgutz/ansi")
- (synopsis "Small, fast library to create ANSI colored strings and codes")
- (description "This package provides @code{ansi}, a Go module that can
-generate ANSI colored strings.")
- (license license:expat))))
-
(define-public go-github-com-aarzilli-golua
(let ((commit "03fc4642d792b1f2bc5e7343b403cf490f8c501d")
(revision "0"))