summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:28:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:07 +0300
commit9951b78e4472a9539d9ed6980ff61f007e544cb1 (patch)
treef813e206c1c8f5f816e0f649b8df2640b015940d
parentd2a6bff06b34505cf788f67afeb321381f0c8031 (diff)
gnu: Add rust-stable-deref-trait.
* gnu/packages/crates-io.scm (rust-stable-deref-trait): New variable.
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index acb4873939..b26967b3df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1361,6 +1361,30 @@ spinning. They may contain data, are usable without @code{std},and static
initializers are available.")
(license license:expat)))
+(define-public rust-stable-deref-trait
+ (package
+ (name "rust-stable-deref-trait")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "stable_deref_trait" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j2lkgakksmz4vc5hfawcch2ipiskrhjs1sih0f3br7s7rys58fv"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/storyyeller/stable_deref_trait0")
+ (synopsis "Defines an unsafe marker trait, StableDeref")
+ (description
+ "This crate defines an unsafe marker trait, StableDeref, for container
+types which deref to a fixed address which is valid even when the containing
+type is moved. For example, Box, Vec, Rc, Arc and String implement this trait.
+Additionally, it defines CloneStableDeref for types like Rc where clones deref
+to the same address.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-stdweb-internal-runtime
(package
(name "rust-stdweb-internal-runtime")