summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-23 00:28:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:21 -0400
commit9d31c06992e631167918b04db53c1c281f60222b (patch)
tree0b967f559f194624335507cfe7fbd57f51a67b17
parent68d7bc9ee518fd8d4485b1da89180860173e4481 (diff)
gnu: Add python-stack-data.
* gnu/packages/python-xyz.scm (python-stack-data): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 87c9bb015c..622af01927 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9072,6 +9072,32 @@ for automated refactoring or highlighting.")
functions, useful in the context of writing unit tests among other uses.")
(license license:expat)))
+(define-public python-stack-data
+ (package
+ (name "python-stack-data")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stack_data" version))
+ (sha256
+ (base32 "04lfcj5qrn4qikjw89qbdzqwm0xm4bgm4m8rll1rafk3pm0jssa5"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-asttokens python-executing python-pure-eval))
+ (native-inputs
+ (list python-cython
+ python-littleutils
+ python-pygments
+ python-pytest
+ python-setuptools-scm
+ python-typeguard))
+ (home-page "https://github.com/alexmojaki/stack_data")
+ (synopsis "Python stack frame and traceback manipulation library")
+ (description "The @code{stack_data} Python library extracts data from
+stack frames and tracebacks. Is can be used to display more useful tracebacks
+than the default.")
+ (license license:expat)))
+
(define-public python-ipython
(package
(name "python-ipython")