summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-08-30 00:25:58 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2021-09-02 20:47:12 +0100
commit9f7c4f380fdd86d81c805b72e4d05e9e658d3dc2 (patch)
tree3ced352d7db2a7d49beb3d75600aa4494c5c574f
parentf6e80d4e1601346878aecc394c0855eda3ed75d9 (diff)
gnu: esbuild: Disable race detector on 32-bit targets.
* gnu/packages/web.scm (esbuild)[arguments]: Set the ESBUILD_RACE variable to an empty string to remove the -race option.
-rw-r--r--gnu/packages/web.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f0ac9ccee2..5817d2dd95 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1672,13 +1672,17 @@ used to validate and fix HTML data.")
#t))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/evanw/esbuild/cmd/esbuild"
+ `(#:import-path "github.com/evanw/esbuild/cmd/esbuild"
#:unpack-path "github.com/evanw/esbuild"
#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? unpack-path #:allow-other-keys)
(when tests?
+ ;; The "Go Race Detector" is only supported on 64-bit
+ ;; platforms, this variable disables it.
+ (unless ,(target-64bit?)
+ (setenv "ESBUILD_RACE" ""))
(with-directory-excursion (string-append "src/" unpack-path)
(invoke "make" "test-go")))
#t)))))