summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:30 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:45:41 -0500
commita0981f91824887e211b23f7dacdd62388a6206b8 (patch)
tree5c8947ca642abab47c8dbf8bea932b6b0b2a35a1
parentecc9c4c3f6a7cb88038d80729deafaba991f56f1 (diff)
gnu: Add go-github-com-nxadm-tail.
* gnu/packages/golang.scm (go-github-com-nxadm-tail): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bfc1e6ad05..4d7a1b2be8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4071,6 +4071,30 @@ application's http.Handlers.")
(description "File system notifications for Go")
(license license:bsd-3)))
+(define-public go-github-com-nxadm-tail
+ (package
+ (name "go-github-com-nxadm-tail")
+ (version "1.4.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nxadm/tail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j2gi485fhwdpmyzn42wk62103fclwbfywg42p275z1qv2bsz1rc"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/nxadm/tail"))
+ (propagated-inputs (list go-gopkg-in-tomb-v1
+ go-github-com-fsnotify-fsnotify))
+ (home-page "https://github.com/nxadm/tail")
+ (synopsis "Go implementation of the functionality of @command{tail -f}")
+ (description
+ "This package provides a Go library for reading from continuously
+updating files, like @command{tail -f}.")
+ (license license:expat)))
+
(define-public go-github-com-magiconair-properties
(package
(name "go-github-com-magiconair-properties")