summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 10:31:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:50:58 +0100
commita0c693e17391663d7fbd5d88d96c082c0fa0f3a9 (patch)
treed32b1aabc3bf8a8a69214b9a15cb3506a973dea6
parente956d76ddb6448ded1add1f74a4ed8f68e8f6029 (diff)
gnu: thefuck: Don't use unstable tarball.
* gnu/packages/admin.scm (thefuck)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/admin.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bb6bcaea9b..3fc9e9ef6e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2015,15 +2015,16 @@ throughput (in the same interval).")
(package
(name "thefuck")
(version "3.28")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/nvbn/thefuck/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1i11qlnbg95nx7dcf6wqvfz7b230dqr5m981md4hvyaa1qw3xj5m"))
- (patches (search-patches "thefuck-test-environ.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nvbn/thefuck.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "070b2sx8r0b4hry6xg97psxlikxghmz91zicg2cm6kc1yhgz4agc"))
+ (patches (search-patches "thefuck-test-environ.patch"))))
(build-system python-build-system)
(arguments
'(#:phases