summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 19:10:17 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 19:10:17 +0200
commita338b6f51d185cf80d387d3c20a96d89c53d45e7 (patch)
tree4f5354abaee8a4844bf2592cf1654c2cc7e0f8e2
parentbb82c3d42bb95588f40394f4d71f915654c0e643 (diff)
Revert "gnu: emacs: Update to 26.1."
This reverts commit bb82c3d42bb95588f40394f4d71f915654c0e643. This commit needs probably to be done on core-updates.
-rw-r--r--gnu/packages/emacs.scm7
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
2 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fbe188f4ef..fc7f52a327 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -114,14 +114,14 @@
(define-public emacs
(package
(name "emacs")
- (version "26.1")
+ (version "25.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/emacs/emacs-"
version ".tar.xz"))
(sha256
(base32
- "0b6k1wq44rc8gkvxhi1bbjxbz3cwg29qbq8mklq2az6p1hjgrx0w"))
+ "02y00y9q42g1iqgz5qhmsja75hwxd88yrn9zp14lanay0zkwafi5"))
(patches (search-patches "emacs-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
"emacs-source-date-epoch.patch"))
@@ -159,8 +159,7 @@
" ")))))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-/bin/pwd
(lambda _
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index 4b7904ea3b..c5a426802c 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el
-@@ -494,6 +494,12 @@ indentation."
- (> (length function) 3)
- (string-match "\\`def" function)))
- (lisp-indent-defform state indent-point))
+@@ -482,6 +482,12 @@
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
+ ((and (null method)
+ (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function))
+ (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point)))
- ((integerp method)
- (lisp-indent-specform method state
- indent-point normal-indent))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))