summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-19 16:50:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-18 23:56:25 +0200
commita78c494b8b504cd31d8e67c818183e40f20b789d (patch)
tree79e7ee4ac40be1b23e52e079d216716a488f0ffe
parent4b48201942c22f75da19bc38aa0228ead2703fa6 (diff)
gnu: emacs-nyxt: Update to 0.1.0-0.5f732e3.
* gnu/packages/emacs-xyz.scm (emacs-nyxt): Update to 0.1.0-0.5f732e3. Change-Id: Id387b52fd12a3b46eb0c1a9a9c7d3799c6d717eb Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm59
1 files changed, 31 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8ee841e687..26671853e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30286,35 +30286,38 @@ comments.")
(license license:lgpl2.1+)))
(define-public emacs-nyxt
- (package
- (name "emacs-nyxt")
- (version "0.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~conses/nyxt.el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1hgb10pk5m3v2gsl4h6i821nyzksss0rk4hhjnfb7nm98lalzbl6"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-file-name
- (lambda* (#:key inputs #:allow-other-keys)
- (emacs-substitute-variables "nyxt.el"
- ("nyxt-path"
- (search-input-file inputs "/bin/nyxt"))))))))
- (inputs (list nyxt))
- (propagated-inputs (list emacs-sly))
- (home-page "https://git.sr.ht/~conses/nyxt.el")
- (synopsis "Interact with Nyxt from Emacs")
- (description "This package consists of custom logic to interact with Nyxt
+ ;; This forge doesn't support fetching from refs, use commits.
+ (let ((commit "5f732e3d039c9d9c316dd5fbbbc91bd015dd2659")
+ (revision "0"))
+ (package
+ (name "emacs-nyxt")
+ (version (git-version "0.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.migalmoreno.com/nyxt.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "147yin822mi49gg2gxqljnx3i261z6b8d61m83l4nns4cf67vqns"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "nyxt.el"
+ ("nyxt-path"
+ (search-input-file inputs "/bin/nyxt"))))))))
+ (inputs (list nyxt))
+ (propagated-inputs (list emacs-sly))
+ (home-page "https://git.migalmoreno.com/nyxt.el")
+ (synopsis "Interact with Nyxt from Emacs")
+ (description "This package consists of custom logic to interact with Nyxt
from Emacs.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-libmpdel
(package