summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-07 15:52:39 -0500
committerLeo Famulari <leo@famulari.name>2021-03-25 19:19:42 -0400
commita801c7379a534a2896a03a1a6f8b47eb92691b00 (patch)
tree777908afa9d55f8922fe618fdb7fa29383219732
parent0d8cea4f247272a36c307276253f014f271f1b56 (diff)
gnu: Remove QT 4.
For more information, see: https://lists.gnu.org/archive/html/guix-devel/2016-02/msg00596.html https://bugs.gnu.org/45704 * gnu/packages/qt.scm (qt-4, python2-pyqt-4): Remove variables. * gnu/packages/engineering.scm (qucs, qucs-s): Remove variables. * gnu/packages/messaging.scm (pybitmessage): Remove variable. * gnu/packages/password-utils.scm (keepassx): Remove variable. * gnu/packages/pdf.scm (poppler-qt4): Remove variable.
-rw-r--r--gnu/packages/engineering.scm250
-rw-r--r--gnu/packages/messaging.scm93
-rw-r--r--gnu/packages/password-utils.scm31
-rw-r--r--gnu/packages/pdf.scm7
-rw-r--r--gnu/packages/qt.scm251
5 files changed, 0 insertions, 632 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f3c6e6f3cd..8d7ba9c1da 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2016,256 +2016,6 @@ parallel computing platforms. It also supports serial execution.")
(license (list license:gpl2+
license:lgpl2.0+)))) ; freehdl's libraries
-(define-public qucs
- ;; Qucs 0.0.19 segfaults when using glibc-2.26. Temporarily build from git.
- ;; TODO: When qucs-0.0.20 is released, revert the commit that introduced this
- ;; comment and update the package.
- (let ((commit "b4f27d9222568066cd59e4c387c51a35056c99d8")
- (revision "0"))
- (package
- (name "qucs")
- (version (git-version "0.0.19" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Qucs/qucs")
- (commit commit)))
- (sha256
- (base32 "10bclay9xhkffmsh4j4l28kj1qpxx0pnxja5vx6305cllnq4r3gb"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'patch-bootstrap
- (lambda _
- (for-each patch-shebang
- '("bootstrap"
- "qucs/bootstrap"
- "qucs-doc/bootstrap"
- "qucs-core/bootstrap"))
- #t))
- (add-before 'configure 'patch-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "qucs/configure"
- (("\\$QTDIR") (assoc-ref inputs "qt4")))
- #t))
- (add-after 'patch-configure 'patch-scripts
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* '("qucs/qucs/qucsdigi"
- "qucs/qucs/qucsdigilib"
- "qucs/qucs/qucsveri")
- (("\\$BINDIR")
- (string-append (assoc-ref outputs "out") "/bin"))
- (("freehdl-config")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-config"))
- (("freehdl-v2cc")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-v2cc"))
- (("cp ")
- (string-append (assoc-ref inputs "coreutils") "/bin/cp "))
- (("glibtool")
- (string-append (assoc-ref inputs "libtool") "/bin/libtool"))
- (("sed")
- (string-append (assoc-ref inputs "sed") "/bin/sed"))
- (("iverilog")
- (string-append (assoc-ref inputs "iverilog") "/bin/iverilog"))
- (("vvp")
- (string-append (assoc-ref inputs "iverilog") "/bin/vvp")))
- #t))
- (add-before 'check 'pre-check
- (lambda _
- ;; The test suite requires a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- #t))
- (add-after 'install 'make-wrapper
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; 'qucs' directly invokes gcc, hence this wrapping.
- (wrap-program (string-append out "/bin/qucs")
- `("CPLUS_INCLUDE_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/include")))
- `("PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/bin")))
- `("LIBRARY_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/lib")))
- `("ADMSXMLBINDIR" ":" prefix
- (,(string-append (assoc-ref inputs "adms") "/bin")))
- `("ASCOBINDIR" ":" prefix
- (,(string-append (assoc-ref inputs "asco") "/bin")))
- `("QUCS_OCTAVE" ":" prefix
- (,(string-append (assoc-ref inputs "octave") "/bin/octave")))))
- #t)))
- #:parallel-build? #f ; race condition
- #:configure-flags '("--disable-doc"))) ; we need octave-epstk
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bison" ,bison)
- ("flex" ,flex)
- ("gperf" ,gperf)
- ("libtool-native" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-2) ; for tests
- ("matplotlib" ,python2-matplotlib) ; for tests
- ("numpy" ,python2-numpy) ; for tests
- ("xorg-server" ,xorg-server-for-tests))) ; for tests
- (inputs
- `(("adms" ,adms)
- ("asco" ,asco)
- ("coreutils" ,coreutils)
- ("freehdl" ,freehdl)
- ("gcc-toolchain" ,gcc-toolchain)
- ("iverilog" ,iverilog)
- ("libtool" ,libtool)
- ("octave" ,octave-cli)
- ("qt4" ,qt-4)
- ("sed" ,sed)))
- (home-page "http://qucs.sourceforge.net/")
- (synopsis "Circuit simulator with graphical user interface")
- (description
- "Qucs is a circuit simulator with graphical user interface. The software
-aims to support all kinds of circuit simulation types---e.g. DC, AC,
-S-parameter, transient, noise and harmonic balance analysis. Pure digital
-simulations are also supported.")
- (license license:gpl2+))))
-
-(define-public qucs-s
- (package
- (name "qucs-s")
- (version "0.0.21")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ra3xdh/qucs_s/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "12m1jwhb9qwvb141qzyskbxnw3wn1x22d02z4b4862p7xvccl5h7"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-scripts
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("qucs/qucsdigi"
- "qucs/qucsdigilib"
- "qucs/qucsveri")
- (("\\$BINDIR")
- (string-append (assoc-ref inputs "qucs") "/bin"))
- (("freehdl-config")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-config"))
- (("freehdl-v2cc")
- (string-append (assoc-ref inputs "freehdl") "/bin/freehdl-v2cc"))
- (("cp ")
- (string-append (assoc-ref inputs "coreutils") "/bin/cp "))
- (("glibtool")
- (string-append (assoc-ref inputs "libtool") "/bin/libtool"))
- (("sed")
- (string-append (assoc-ref inputs "sed") "/bin/sed"))
- (("iverilog")
- (string-append (assoc-ref inputs "iverilog") "/bin/iverilog"))
- (("vvp")
- (string-append (assoc-ref inputs "iverilog") "/bin/vvp")))
- #t))
- (add-after 'patch-scripts 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "qucs/main.cpp"
- (((string-append "QucsSettings\\.Qucsator = QucsSettings\\.BinDir "
- "\\+ \"qucsator\" \\+ executableSuffix"))
- (string-append "}{ QucsSettings.Qucsator = \""
- (assoc-ref inputs "qucs") "/bin/qucsator\""))
- (((string-append "QucsSettings\\.XyceExecutable = "
- "\"/usr/local/Xyce-Release-6.8.0-OPENSOURCE/bin/Xyce"))
- (string-append "}{ QucsSettings.XyceExecutable = \""
- (assoc-ref inputs "xyce-serial") "/bin/Xyce"))
- (((string-append "else QucsSettings\\.XyceParExecutable = "
- "\"mpirun -np %p /usr/local"
- "/Xyce-Release-6.8.0-OPENMPI-OPENSOURCE/bin/Xyce"))
- (string-append "QucsSettings.XyceParExecutable = \""
- (assoc-ref inputs "mpi") "/bin/mpirun -np %p "
- (assoc-ref inputs "xyce-parallel") "/bin/Xyce"))
- (("else QucsSettings\\.NgspiceExecutable = \"ngspice\"")
- (string-append "QucsSettings.NgspiceExecutable = " "\""
- (assoc-ref inputs "ngspice") "/bin/ngspice\"")))
- (substitute* "qucs/extsimkernels/ngspice.cpp"
- (("share/qucs/xspice_cmlib") "share/qucs-s/xspice_cmlib"))
- (substitute* "qucs/qucs_actions.cpp"
- (("qucstrans")
- (string-append (assoc-ref inputs "qucs") "/bin/qucstrans"))
- (("qucsattenuator")
- (string-append (assoc-ref inputs "qucs") "/bin/qucsattenuator"))
- (("qucsrescodes")
- (string-append (assoc-ref inputs "qucs") "/bin/qucsrescodes")))
- #t))
- (add-after 'install 'install-scripts
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (for-each
- (lambda (script)
- (let ((file (string-append "../qucs_s-" ,version
- "/qucs/" script))
- (out (assoc-ref outputs "out")))
- (install-file file (string-append out "/bin"))
- (chmod (string-append out "/bin/" script) #o555)))
- '("qucsdigi" "qucsdigilib" "qucsveri"))
- #t))
- (add-after 'install-scripts 'make-wrapper
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (file (string-append out "/bin/qucs-s"))
- (qucs (assoc-ref inputs "qucs"))
- (qucsator (string-append qucs "/bin/qucsator")))
- (wrap-program file
- `("CPLUS_INCLUDE_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/include")))
- `("PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/bin")))
- `("LIBRARY_PATH" ":" prefix
- (,(string-append (assoc-ref inputs "gcc-toolchain")
- "/lib")))
- `("QUCSATOR" ":" prefix (,qucsator))
- `("QUCSCONV" ":" prefix (,(string-append qucsator "/bin/qucsconv")))
- `("ADMSXMLBINDIR" ":" prefix (,(string-append (assoc-ref inputs "adms")
- "/bin")))
- `("ASCOBINDIR" ":" prefix (,(string-append (assoc-ref inputs "asco")
- "/bin")))
- `("QUCS_OCTAVE" ":" prefix (,(string-append (assoc-ref inputs "octave")
- "/bin/octave"))))
- (symlink qucsator (string-append out "/bin/qucsator"))
- #t))))))
- (native-inputs
- `(("libtool-native" ,libtool)))
- (inputs
- `(("adms" ,adms)
- ("asco" ,asco)
- ("coreutils" ,coreutils)
- ("freehdl" ,freehdl)
- ("gcc-toolchain" ,gcc-toolchain)
- ("iverilog" ,iverilog)
- ("libtool" ,libtool)
- ("mpi" ,openmpi)
- ("ngspice" ,ngspice)
- ("octave" ,octave-cli)
- ("qt4" ,qt-4)
- ("qucs" ,qucs)
- ("sed" ,sed)
- ("xyce-serial" ,xyce-serial)
- ("xyce-parallel" ,xyce-parallel)))
- (home-page "https://ra3xdh.github.io/")
- (synopsis "Circuit simulator with graphical user interface")
- (description
- "Qucs-S is a spin-off of the Qucs cross-platform circuit simulator.
-The S letter indicates SPICE. The purpose of the Qucs-S subproject is to use
-free SPICE circuit simulation kernels with the Qucs GUI. It provides the
-simulator backends @code{Qucsator}, @code{ngspice} and @code{Xyce}.")
- (license license:gpl2+)))
-
(define-public librepcb
(package
(name "librepcb")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a967ac31c2..5c55e08fb2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1616,99 +1616,6 @@ guidelines. It provides an easy to use application that allows you to
connect with friends and family without anyone else listening in.")
(license license:gpl3+)))
-(define-public pybitmessage
- (package
- (name "pybitmessage")
- (version "0.6.3.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Bitmessage/PyBitmessage")
- (commit version)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1lmhbpwsqh1v93krlqqhafw2pc3y0qp8zby186yllbph6s8kdp35"))))
- (propagated-inputs
- ;; TODO:
- ;; Package "pyopencl", required in addition to numpy for OpenCL support.
- ;; Package "gst123", required in addition to alsa-utils and
- ;; mpg123 for sound support.
- `(("python2-msgpack" ,python2-msgpack)
- ("python2-pythondialog" ,python2-pythondialog)
- ("python2-pyqt-4" ,python2-pyqt-4)
- ("python2-sip" ,python2-sip)
- ("python2-pysqlite" ,python2-pysqlite)
- ("python2-pyopenssl" ,python2-pyopenssl)))
- (native-inputs
- `(("openssl" ,openssl)))
- (build-system python-build-system)
- (arguments
- `(#:modules ((guix build python-build-system)
- (guix build utils))
- #:tests? #f ;no test target
- #:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-unmatched-python-shebangs
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/bitmessagemain.py"
- (("#!/usr/bin/env python2.7")
- (string-append "#!" (which "python"))))
- (substitute* "src/bitmessagecli.py"
- (("#!/usr/bin/env python2.7.x")
- (string-append "#!" (which "python"))))
- #t))
- (add-after 'unpack 'fix-depends
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/depends.py"
- (("libcrypto.so")
- (string-append (assoc-ref inputs "openssl")
- "/lib/libcrypto.so")))
- #t))
- (add-after 'unpack 'fix-local-files-in-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/proofofwork.py"
- (("bitmsghash.so")
- (string-append (assoc-ref outputs "out")
- "/lib/bitmsghash.so")))
- #t))
- (add-after 'unpack 'fix-pyelliptic
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/pyelliptic/openssl.py"
- (("libcrypto.so")
- (string-append (assoc-ref inputs "openssl")
- "/lib/libcrypto.so"))
- (("libssl.so")
- (string-append (assoc-ref inputs "openssl")
- "/lib/libssl.so")))
- #t))
- (add-after 'unpack 'noninteractive-build
- ;; This applies upstream commit 4c597d3f7cf9f83a763472aa165a1a4292019f20
- (lambda _
- (substitute* "setup.py"
- (("except NameError")
- "except EOFError, NameError"))
- #t))
- ;; XXX: python setup.py does not build and install bitmsghash,
- ;; without it PyBitmessage tries to compile it at first run
- ;; in the store, which due to obvious reasons fails. Do it
- ;; and place it in /lib.
- (add-after 'unpack 'build-and-install-bitmsghash
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion "src/bitmsghash"
- (system* "make")
- (install-file "bitmsghash.so"
- (string-append (assoc-ref outputs "out") "/lib")))
- #t)))))
- (license license:expat)
- (description
- "Distributed and trustless peer-to-peer communications protocol
-for sending encrypted messages to one person or many subscribers.")
- (synopsis "Distributed peer-to-peer communication")
- (home-page "https://bitmessage.org/")))
-
(define-public ytalk
(package
(name "ytalk")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 0d86a3d69e..d7942a0f8b 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -179,37 +179,6 @@ algorithms AES or Twofish.")
;; the combined work falls under the GPLv3.
(license license:gpl3)))
-(define-public keepassx
- (package
- (name "keepassx")
- (version "2.0.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.keepassx.org/releases/" version
- "/keepassx-" version ".tar.gz"))
- (sha256
- (base32
- "1ia7cqx9ias38mnffsl7da7g1f66bcbjsi23k49sln0c6spb9zr3"))))
- (build-system cmake-build-system)
- (inputs
- `(("libgcrypt" ,libgcrypt)
- ("libxi" ,libxi)
- ("libxtst" ,libxtst)
- ("qt" ,qt-4)))
- (native-inputs
- `(("zlib" ,zlib)))
- (home-page "https://www.keepassx.org")
- (synopsis "Password manager")
- (description "KeePassX is a password manager or safe which helps you to
-manage your passwords in a secure way. You can put all your passwords in one
-database, which is locked with one master key or a key-file which can be stored
-on an external storage device. The databases are encrypted using the
-algorithms AES or Twofish.")
- ;; Non functional parts use various licences.
- (license license:gpl3)
- (properties `((superseded . ,keepassxc)))))
-
(define-public pwsafe
(package
(name "pwsafe")
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 437000b7c0..00468fa814 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -299,13 +299,6 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(license (list license:bsd-3
license:gpl2))))
-(define-public poppler-qt4
- (package/inherit poppler
- (name "poppler-qt4")
- (inputs `(("qt-4" ,qt-4)
- ,@(package-inputs poppler)))
- (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
-
(define-public poppler-qt5
(package/inherit poppler
(name "poppler-qt5")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d718b520bd..21ccf15dc3 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -277,210 +277,6 @@ other text such as code. The syntax uses the syntax of the Django template
system, and the core design of Django is reused in Grantlee.")
(license license:lgpl2.1+)))
-(define-public qt-4
- (package
- (name "qt")
- (version "4.8.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://download.qt-project.org/archive/qt/"
- (string-copy version 0 (string-rindex version #\.))
- "/" version
- "/qt-everywhere-opensource-src-"
- version ".tar.gz"))
- (sha256
- (base32
- "183fca7n7439nlhxyg1z7aky0izgbyll3iwakw4gwivy16aj5272"))
- (patches (search-patches "qt4-ldflags.patch"))
- (modules '((guix build utils)))
- (snippet
- ;; Remove webkit module, which is not built.
- '(begin (delete-file-recursively "src/3rdparty/webkit")
- #t))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("mesa" ,mesa)))
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("bluez" ,bluez)
- ("cups" ,cups)
- ("dbus" ,dbus)
- ("double-conversion" ,double-conversion)
- ("expat" ,expat)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("glib" ,glib)
- ("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)
- ("icu4c" ,icu4c)
- ("jasper" ,jasper)
- ("libinput" ,libinput-minimal)
- ("libmng" ,libmng)
- ("libpci" ,pciutils)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp)
- ("libx11" ,libx11)
- ("libxcomposite" ,libxcomposite)
- ("libxcursor" ,libxcursor)
- ("libxext" ,libxext)
- ("libxfixes" ,libxfixes)
- ("libxi" ,libxi)
- ("libxinerama" ,libxinerama)
- ("libxkbcommon" ,libxkbcommon)
- ("libxml2" ,libxml2)
- ("libxrandr" ,libxrandr)
- ("libxrender" ,libxrender)
- ("libxslt" ,libxslt)
- ("libxtst" ,libxtst)
- ("mtdev" ,mtdev)
- ("mariadb-dev" ,mariadb "dev")
- ("nss" ,nss)
- ("postgresql" ,postgresql)
- ("pulseaudio" ,pulseaudio)
- ("pcre2" ,pcre2)
- ("sqlite" ,sqlite)
- ("udev" ,eudev)
- ("unixodbc" ,unixodbc)
- ("wayland" ,wayland)
- ("xcb-util" ,xcb-util)
- ("xcb-util-image" ,xcb-util-image)
- ("xcb-util-keysyms" ,xcb-util-keysyms)
- ("xcb-util-renderutil" ,xcb-util-renderutil)
- ("xcb-util-wm" ,xcb-util-wm)
- ("zlib" ,zlib)
- ("libjpeg" ,libjpeg-turbo)
- ("libsm" ,libsm)
- ("openssl" ,openssl-1.0)))
- (native-inputs
- `(;; XXX: The JavaScriptCore engine does not build with the C++11 standard.
- ;; We could build it with -std=gnu++98, but then we'll get in trouble with
- ;; ICU later. Just keep using GCC 5 for now.
- ("gcc@5" ,gcc-5)
- ("bison" ,bison)
- ("flex" ,flex)
- ("gperf" ,gperf)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python-2)
- ("ruby" ,ruby)
- ("which" ,(@ (gnu packages base) which))))
- ;; Note: there are 37 MiB of examples and a '-exampledir' configure flags,
- ;; but we can't make them a separate output because "out" and "examples"
- ;; would refer to each other.
- (outputs '("out" ;112MiB core + 37MiB examples
- "doc")) ;280MiB of HTML + code
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'set-paths 'hide-default-gcc
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gcc (assoc-ref inputs "gcc")))
- ;; Remove the default GCC from CPLUS_INCLUDE_PATH to prevent
- ;; conflicts with the GCC 5 input.
- (setenv "CPLUS_INCLUDE_PATH"
- (string-join
- (delete (string-append gcc "/include/c++")
- (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
- ":"))
- #t)))
- (replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (substitute* '("configure")
- (("/bin/pwd") (which "pwd")))
- (substitute* "src/corelib/global/global.pri"
- (("/bin/ls") (which "ls")))
-
- (invoke
- "./configure"
- "-verbose"
- "-prefix" out
- "-nomake" "examples demos"
- ;; Note: Don't pass '-docdir' since 'qmake' and
- ;; libQtCore would record its value, thereby defeating
- ;; the whole point of having a separate output.
- "-datadir" (string-append out "/share/qt-" ,version
- "/data")
- "-importdir" (string-append out "/lib/qt-4"
- "/imports")
- "-plugindir" (string-append out "/lib/qt-4"
- "/plugins")
- "-translationdir" (string-append out "/share/qt-" ,version
- "/translations")
- "-demosdir" (string-append out "/share/qt-" ,version
- "/demos")
- "-examplesdir" (string-append out "/share/qt-" ,version
- "/examples")
- "-opensource"
- "-confirm-license"
- ;; explicitly link with dbus instead of dlopening it
- "-dbus-linked"
- ;; Skip the webkit module; it fails to build on armhf
- ;; and, apart from that, may pose security risks.
- "-no-webkit"
- ;; don't use the precompiled headers
- "-no-pch"
- ;; drop special machine instructions not supported
- ;; on all instances of the target
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '()
- '("-no-mmx"
- "-no-3dnow"
- "-no-sse"
- "-no-sse2"))
- "-no-sse3"
- "-no-ssse3"
- "-no-sse4.1"
- "-no-sse4.2"
- "-no-avx"))))
- (add-after
- 'install 'move-doc
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Because of qt4-documentation-path.patch, documentation ends up
- ;; being installed in OUT. Move it to the right place.
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (olddoc (string-append out "/doc"))
- (docdir (string-append doc "/share/doc/qt-" ,version)))
- (mkdir-p (dirname docdir))
-
- ;; Note: We can't use 'rename-file' here because OUT and DOC are
- ;; different "devices" due to bind-mounts.
- (copy-recursively olddoc docdir)
- (delete-file-recursively olddoc)
- #t))))))
- (native-search-paths
- (list (search-path-specification
- (variable "QMAKEPATH")
- (files '("lib/qt5")))
- (search-path-specification
- (variable "QML2_IMPORT_PATH")
- (files '("lib/qt5/qml")))
- (search-path-specification
- (variable "QT_PLUGIN_PATH")
- (files '("lib/qt5/plugins")))
- (search-path-specification
- (variable "XDG_DATA_DIRS")
- (files '("share")))
- (search-path-specification
- (variable "XDG_CONFIG_DIRS")
- (files '("etc/xdg")))))
- (home-page "https://www.qt.io/")
- (synopsis "Cross-platform GUI library")
- (description "Qt is a cross-platform application and UI framework for
-developers using C++ or QML, a CSS & JavaScript like language.")
- (license (list license:lgpl2.1 license:lgpl3))
-
- ;; Qt 4: 'QBasicAtomicPointer' leads to build failures on MIPS;
- ;; see <http://hydra.gnu.org/build/112828>.
- ;; Qt 5: assembler error; see <http://hydra.gnu.org/build/112526>.
- (supported-systems (delete "mips64el-linux" %supported-systems))))
-
(define (qt5-urls component version)
"Return a list of URLs for VERSION of the Qt5 COMPONENT."
;; We can't use a mirror:// scheme because these URLs are not exact copies:
@@ -2286,53 +2082,6 @@ itself.")
("qtwebchannel" ,qtwebchannel)
("qtwebengine" ,qtwebengine)))))
-(define-public python2-pyqt-4
- (package (inherit python-pyqt)
- (name "python2-pyqt")
- (version "4.12.3")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "mirror://sourceforge/pyqt/PyQt4/"
- "PyQt-" version "/PyQt4_gpl_x11-"
- version ".tar.gz"))
- (sha256
- (base32
- "0wnlasg62rm5d39nq1yw4namcx2ivxgzl93r5f2vb9s0yaz5l3x0"))))
- (native-inputs
- `(("qt" ,qt-4)))
- (inputs `(("python" ,python-2)))
- (propagated-inputs
- `(("python-sip" ,python2-sip)))
- (arguments
- `(#:tests? #f ; no check target
- #:modules ((srfi srfi-1)
- ,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (sip (string-append out "/share/sip"))
- (python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2)
- "."))
- (lib (string-append out "/lib/python"
- python-major+minor
- "/site-packages")))
- (invoke "python" "configure.py"
- "--confirm-license"
- "--bindir" bin
- "--destdir" lib
- "--sipdir" sip)))))))
- (license (list license:gpl2 license:gpl3)))) ; choice of either license
-
(define-public python-qtpy
(package
(name "python-qtpy")