summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-10-27 09:46:02 -0400
committerChristopher Baines <mail@cbaines.net>2023-10-30 11:17:42 +0000
commita85cbaa437d736eb63ac47fc2c52b99bafdfed4b (patch)
tree1b9d67b246f990bbcf3dd390678ead156c13bdf8
parent549d7ce3b3ea502e5bc7be6f66f886b6ee81f9e8 (diff)
gnu: ansible-core: Update to 2.15.5 and fix tests.
* gnu/packages/admin.scm (ansible-core): Update to 2.15.5. [#:phases]<check>: Enable tests that now pass and choose the right ansible-test to invoke. [propagated-inputs]: Replace python-resolvelib-0.5 with python-resolvelib. Change-Id: Ibda3222a16fefb1484affdb62e38a3a07ce61986 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/admin.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 67d836112d..9e28d2e8c0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2835,13 +2835,13 @@ specified directories.")
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.14.4")
+ (version "2.15.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible-core" version))
(sha256
- (base32 "057g87smxcn6zc558xk4zr6ga4q8clmkyxghn5gx60a94sy61clh"))))
+ (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -2911,14 +2911,6 @@ test_context)" all)
(when tests?
;; Otherwise Ansible fails to create its config directory.
(setenv "HOME" "/tmp")
- ;; This test module messes up with sys.path and causes many
- ;; test failures.
- (delete-file "test/units/_vendor/test_vendor.py")
- ;; The test fails when run in the container, for reasons
- ;; unknown.
- (delete-file "test/units/utils/test_display.py")
- ;; This test fail for reasons unknown.
- (delete-file "test/units/cli/test_adhoc.py")
;; These tests fail in the container; it appears that the
;; mocking of the absolute file names such as /usr/bin/svcs do
;; not work as intended there.
@@ -2933,7 +2925,7 @@ test_command_nonexisting.py")
;; does some extra environment setup. Taken from
;; https://raw.githubusercontent.com/ansible/ansible/\
;; devel/test/utils/shippable/shippable.sh.
- (invoke "ansible-test" "units" "-v"
+ (invoke "./bin/ansible-test" "units" "-v"
"--num-workers" (number->string
(parallel-job-count)))))))))
(native-inputs
@@ -2954,7 +2946,7 @@ test_command_nonexisting.py")
python-jinja2
python-pyyaml
python-packaging ;for version number parsing
- python-resolvelib-0.5))
+ python-resolvelib))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.