summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2023-11-11 16:35:32 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:28 +0200
commita8f0f4a2726dea828711c6e0e32c779ea7de96b1 (patch)
treebbf209b3147951c686d093b85cc5a45deb5a2994
parent35cac21b5de68fa16c5f3cf5124faf7874c2ce23 (diff)
gnu: Add rust-tungstenite-0.19.
* gnu/packages/crates-io.scm (rust-tungstenite-0.19): New variable. (rust-tungstenite-0.11): Inherit from rust-tungstenite-0.19. Change-Id: Ie65bb3ad45991caeda1831bbcdfb07461bcab41e Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm59
1 files changed, 48 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index db31d10e56..0a0c169b21 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -84740,8 +84740,55 @@ render properties.")
#:cargo-development-inputs
(("rust-env-logger" ,rust-env-logger-0.6))))))
+(define-public rust-tungstenite-0.19
+ (package
+ (name "rust-tungstenite")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0rxzxg4y22rsvdvs4la7igy9117yidc2m6lsfm2hf0xvsska3yqm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-data-encoding" ,rust-data-encoding-2)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-httparse" ,rust-httparse-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-sha1" ,rust-sha1-0.10)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-url" ,rust-url-2)
+ ("rust-utf-8" ,rust-utf-8-0.7)
+ ("rust-webpki" ,rust-webpki-0.22)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.23))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.4)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-input-buffer" ,rust-input-buffer-0.5)
+ ("rust-net2" ,rust-net2-0.2)
+ ("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/snapview/tungstenite-rs")
+ (synopsis "Lightweight stream-based WebSocket implementation")
+ (description
+ "This library provides an implementation of WebSockets, RFC6455. It
+allows for both synchronous (like TcpStream) and asynchronous usage and is
+easy to integrate into any third-party event loops including MIO. The API
+design abstracts away all the internals of the WebSocket protocol but still
+makes them accessible for those who wants full control over the network.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-tungstenite-0.11
(package
+ (inherit rust-tungstenite-0.19)
(name "rust-tungstenite")
(version "0.11.1")
(source
@@ -84751,7 +84798,6 @@ render properties.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "08ra94x3zqkmbsrcmwszknxv2a8g08gk5xlyif3wa037v208sc7h"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -84766,16 +84812,7 @@ render properties.")
("rust-rand" ,rust-rand-0.7)
("rust-sha-1" ,rust-sha-1-0.9)
("rust-url" ,rust-url-2)
- ("rust-utf-8" ,rust-utf-8-0.7))))
- (home-page "https://github.com/snapview/tungstenite-rs")
- (synopsis "Lightweight stream-based WebSocket implementation")
- (description
- "This library provides an implementation of WebSockets, RFC6455. It
-allows for both synchronous (like TcpStream) and asynchronous usage and is
-easy to integrate into any third-party event loops including MIO. The API
-design abstracts away all the internals of the WebSocket protocol but still
-makes them accessible for those who wants full control over the network.")
- (license (list license:expat license:asl2.0))))
+ ("rust-utf-8" ,rust-utf-8-0.7))))))
(define-public rust-twofish-0.7
(package