summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-05 19:26:34 +0200
committerDavid Craven <david@craven.ch>2016-08-28 14:04:51 +0200
commita9ac982a2b4bef711ed7a53221d377251fa6fdc6 (patch)
treee98c8b280138cfe5368cc9fe5201ec48bce04d93
parent8794bd8bb304035a106614854f881749ed131b15 (diff)
gnu: Add python-nltk.
* gnu/packages/python.scm (python-nltk): New variable. (python2-nltk): New variable.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 77996e64b2..0ce25bf5bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10023,3 +10023,30 @@ binary or text.")
(inputs
`(("python2-enum34" ,python2-enum34)
,@(package-inputs base))))))
+
+(define-public python-nltk
+ (package
+ (name "python-nltk")
+ (version "3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "nltk" version))
+ (sha256
+ (base32
+ "0skxbhnymwlspjkzga0f7x1hg3y50fwpfghs8g8k7fh6f4nknlym"))))
+ (build-system python-build-system)
+ (home-page "http://nltk.org/")
+ (synopsis "Natural Language Toolkit")
+ (description "It provides interfaces to over 50 corpora and lexical
+resources such as WordNet, along with a suite of text processing libraries
+for classification, tokenization, stemming, tagging, parsing, and semantic
+reasoning, wrappers for natural language processing libraries.")
+ (license license:asl2.0)
+ (properties `((python2-variant . ,(delay python2-nltk))))))
+
+(define-public python2-nltk
+ (let ((base (package-with-python2 (strip-python2-variant python-nltk))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))