summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-09-18 16:13:17 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-03 13:28:39 +0100
commitab7b6199e321944f94daf19ff28eeb8a65762fa2 (patch)
tree8991bd461cb51bb4d6b74610039a91bf98ca9f17
parent3e06ac60a031f15eb3b9a3ecd29ce9097b1c84d3 (diff)
gnu: Add rust-feedly-api-0.4.
* gnu/packages/crates-io.scm (rust-feedly-api-0.4): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b9a2e41ca2..928f17fe13 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16965,6 +16965,46 @@ Atom, RSS 2.0, RSS 1.0, RSS 0.x and JSON Feed")
"This package provides a Rust implementation of the Feedbin REST API.")
(license license:unlicense)))
+(define-public rust-feedly-api-0.4
+ (package
+ (name "rust-feedly-api")
+ (version "0.4.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "feedly-api" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1knad1bghc8hhfcyl35fcnhrk01vklamq07630rdk0pg6ax04swi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;tests open external connections
+ #:cargo-inputs
+ (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-failure" ,rust-failure-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-percent-encoding"
+ ,rust-percent-encoding-2)
+ ("rust-reqwest" ,rust-reqwest-0.11)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-url" ,rust-url-2))
+ #:cargo-development-inputs
+ (("rust-dotenv" ,rust-dotenv-0.15)
+ ("rust-tokio" ,rust-tokio-1))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://gitlab.com/news-flash/feedly_api")
+ (synopsis "Rust implementation of the feedly REST API")
+ (description
+ "This package provides a Rust implementation of the feedly REST API.")
+ ;; No copyright headers in the source code. LICENSE indicates gpl3.
+ (license license:gpl3)))
+
(define-public rust-femme-2
(package
(name "rust-femme")